It is currently Mon Oct 23, 2017 10:39 pm

All times are UTC - 7 hours





Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sun Feb 08, 2015 7:48 pm 
Offline

Joined: Fri Mar 01, 2013 4:46 am
Posts: 251
so my rom im constructing, has a functional mmc5 split screen, I can adjust it and move it freely. Now, I installed a sound engine into my rom, and when the song comes on, my irq will just vanish, yet, the irq vector and asm is still being logged?

idk if im missing something within the reset vector or what, since this isn't a rom I'm modifying, I'm just inserting things.

Id appreciate any help on this. I'm just so confused on this one. :-/


Top
 Profile  
 
PostPosted: Sun Feb 08, 2015 10:06 pm 
Offline
User avatar

Joined: Sun Sep 19, 2004 9:28 pm
Posts: 3192
Location: Mountain View, CA, USA
Is the sound engine using DMC or tinkering with the DMC registers periodically (particularly $4010 and $4017)? If so, that would likely explain your issue. DMC uses IRQ.

References:

http://wiki.nesdev.com/w/index.php/APU# ... 10-4013.29
http://wiki.nesdev.com/w/index.php/APU_DMC


Top
 Profile  
 
PostPosted: Mon Feb 09, 2015 5:31 am 
Offline

Joined: Fri Mar 01, 2013 4:46 am
Posts: 251
I performed read and write breakpoints to both $4010 and $4017, I initiate the sound engine, and they don't set the debugger off, I get the same result.

Thinking this has to do with my irq. I think I got it figured out.

EDIT_UPDATE

So it was a combination of both my irq asm, and the fact that my JSR for my sound engine, needed to be placed at the very end of my NMI, just before all my PULLS.

I now have no irq issues with the sound engine playing. :-)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group