It is currently Fri Oct 19, 2018 9:26 pm

All times are UTC - 7 hours





Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sat Sep 01, 2018 12:54 pm 
Offline

Joined: Sat Sep 01, 2018 12:39 pm
Posts: 2
This is a question very specific to the Mesen emulator. I really like its debugging tool so far, but I have a dumb little problem with it which I can't seem to solve.

After opening the debug window, I'm unable to resume play in the game window. If I press Continue, it just runs one frame and then pauses/breaks. I don't have any breakpoints anywhere, and I've disabled everything under Break Options. Pause when in debugging tools in the preferences is also disabled. It always breaks on the same instruction, too, an
Code:
lda #$00
early in nmi, part of the controller latch write routine.

Is this by design, or a bug in Mesen, or have I just missed a setting somewhere?


Top
 Profile  
 
PostPosted: Sat Sep 01, 2018 1:21 pm 
Offline

Joined: Sun Feb 07, 2016 6:16 pm
Posts: 525
That's odd - if all the break options are disabled & you have no breakpoints, there should be more or less nothing that should make the debugger break, normally.

Do you get the same behavior in any game, or just this one specific rom?


Top
 Profile  
 
PostPosted: Sat Sep 01, 2018 1:37 pm 
Offline

Joined: Sat Sep 01, 2018 12:39 pm
Posts: 2
No this was exclusively a problem with my own homebrew rom.

However, for some inexplicable reason, the problem stopped occurring after clearing/disabling auto-import of labels, and the enabling them again. I.... have no idea why, but problem solved I guess, so sorry for bothering y'all. Only reason I thought of trying that was after seeing that it didn't happen with other roms, though, so thanks for reminding me to check that. :wink:


Top
 Profile  
 
PostPosted: Sat Sep 01, 2018 3:03 pm 
Offline

Joined: Sun Feb 07, 2016 6:16 pm
Posts: 525
No problem - if you get the same issue again, let me know and I'll try to figure out the cause.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group