Strange issue with PIC16F630 and SuperCIC
Page 1 of 1

Author:  baddflash [ Thu Jan 05, 2017 2:56 pm ]
Post subject:  Strange issue with PIC16F630 and SuperCIC

I recently modded one of my SFC with the super CIC mod and in game reset. Everything seemed to work fine including Starfox2 and mario kart so I was a little surprised when I tried SMRPG and nothing. ????
I tested RPG in an stock SNES and SFC with no issues so the game is fine, though I cleaned it anyway. Starting simple I tried just the SCIC I had been using before and it worked fine, tried another IGR/SCIC board and again worked fine?So with the wiring confirmed I decided to swap the SCIC chip from one that worked and RPG started like normal so the board is fine too. I put the non-working chip in the previously working SCIC board and nothing, ok it's the pic.
I figured it was the programming so I flashed it again, and nothing, tried many times the chip programming and verifying fine each time, still no luck. I confirmed the hex file I was using by re-flashing a working chip, so that wasn't the issue either. Finally I tried flashing the IGR code to the non-working SCIC chip and it seems to function properly there, so I'm using it as the IGR for now.

I can't really say for sure what the issue is but it is confirmed to be this specific IC as all others I have tried seem to work fine. I figure it's the less crucial operation of the IGR is why it will function there. Luckily I installed headers and sockets so testing was simple and it only took about 5 minutes to figure it out.

Just thought it was a strange issue and wanted to share with others that may be having issues that the actual PIC may be the problem, and more importantly make stuff you can take apart, headers and sockets are cheap and make troubleshooting so much easier.

Author:  sanni [ Fri Jan 06, 2017 1:20 am ]
Post subject:  Re: Strange issue with PIC16F630 and SuperCIC

There is a similar thread in a german message board about the snesCIC and the PIC 12F629.

I had the issue that a SFC with several different snesCIC/PIC12F629s would boot everything but SA1 games and only after replacing it with a superCIC/PIC16F630 the SA1 booted fine while the same snesCIC/PIC12F629 would perfectly read SA-1 games in my SNES cartridge reader.

Interestingly the SFC died shortly after so it could be an edge case where a broken SNES only works with certain chips. I did buy a second SFC to clarify but that one already arrived dead from Japan.

Your case is even more interesting since you are using the same code on equal PICs. So it's not just a slight difference between the superCIC and the snesCIC but it can also happen with two superCICs.

Which again leads me to believe that it might be either the fault of a particular picky SNES console or of bad quality control by the PIC manufacturer.
Do you by any chance have a second SNES that you could mod?

I also believe that the CIC in the console could run at slightly different speeds in different consoles since some have a dedicated 4Mhz crystal for the CIC while newer console use a clocksignal from the audio chip, I think. Just speculation though, haven't done any tests.

Author:  baddflash [ Wed Jan 18, 2017 4:17 pm ]
Post subject:  Re: Strange issue with PIC16F630 and SuperCIC

I have a couple other modded consoles right now I will test with them to try and confirm if the snes is to blame or the PIC itself, I hadn't considered the console itself.

Author:  baddflash [ Wed Jan 18, 2017 4:32 pm ]
Post subject:  Re: Strange issue with PIC16F630 and SuperCIC

Tested the same on another cpu-01 and a gpm-02, it would appear the chip itself is at fault.

Page 1 of 1 All times are UTC - 7 hours
Powered by phpBB® Forum Software © phpBB Group