Unknown symbol...

Discussion of hardware and software development for Super NES and Super Famicom.

Moderator: Moderators

Forum rules
  • For making cartridges of your Super NES games, see Reproduction.
LucianoTheWindowsFan
Posts: 28
Joined: Mon Jun 22, 2020 9:39 am

Unknown symbol...

Post by LucianoTheWindowsFan » Mon Jun 22, 2020 9:41 am

Man, I'm disappointed :oops:, I want music in my SNES game but the "unknown symbol" error appears when I compile it so it failed to compile.

tepples
Posts: 22050
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Unknown symbol...

Post by tepples » Mon Jun 22, 2020 12:21 pm

Could you paste the complete error message so that we know which symbol is unknown?

User avatar
Nikku4211
Posts: 102
Joined: Sun Dec 15, 2019 1:28 pm
Location: Bronx, New York
Contact:

Re: Unknown symbol...

Post by Nikku4211 » Tue Jun 23, 2020 2:30 pm

Can you explain what method you are using to put music into your game? Can you explain what format the music is in?
I have an ASD, so empathy is not natural for me. If I hurt you, I apologise.

LucianoTheWindowsFan
Posts: 28
Joined: Mon Jun 22, 2020 9:39 am

Re: Unknown symbol...

Post by LucianoTheWindowsFan » Mon Jul 06, 2020 10:22 am

Nikku4211 wrote:
Tue Jun 23, 2020 2:30 pm
Can you explain what method you are using to put music into your game? Can you explain what format the music is in?
Here's the code in txt
Attachments
code.txt
(8.07 KiB) Downloaded 62 times

User avatar
Nikku4211
Posts: 102
Joined: Sun Dec 15, 2019 1:28 pm
Location: Bronx, New York
Contact:

Re: Unknown symbol...

Post by Nikku4211 » Mon Jul 06, 2020 8:54 pm

LucianoTheWindowsFan wrote:
Mon Jul 06, 2020 10:22 am
Here's the code in txt
Okay, what format did you make the SNES music in first?
I have an ASD, so empathy is not natural for me. If I hurt you, I apologise.

LucianoTheWindowsFan
Posts: 28
Joined: Mon Jun 22, 2020 9:39 am

Re: Unknown symbol...

Post by LucianoTheWindowsFan » Wed Jul 08, 2020 8:51 am

Nikku4211 wrote:
Mon Jul 06, 2020 8:54 pm
LucianoTheWindowsFan wrote:
Mon Jul 06, 2020 10:22 am
Here's the code in txt
Okay, what format did you make the SNES music in first?
SPC700

User avatar
Nikku4211
Posts: 102
Joined: Sun Dec 15, 2019 1:28 pm
Location: Bronx, New York
Contact:

Re: Unknown symbol...

Post by Nikku4211 » Wed Jul 08, 2020 11:18 am

No, not that. Obviously it's going to the SPC700. What program did you make the .SPC music file in?
I have an ASD, so empathy is not natural for me. If I hurt you, I apologise.

LucianoTheWindowsFan
Posts: 28
Joined: Mon Jun 22, 2020 9:39 am

Re: Unknown symbol...

Post by LucianoTheWindowsFan » Thu Jul 09, 2020 2:19 pm

Nikku4211 wrote:
Wed Jul 08, 2020 11:18 am
No, not that. Obviously it's going to the SPC700. What program did you make the .SPC music file in?
I uses SNES GSS

LucianoTheWindowsFan
Posts: 28
Joined: Mon Jun 22, 2020 9:39 am

Re: Unknown symbol...

Post by LucianoTheWindowsFan » Sun Jul 12, 2020 5:08 pm

tepples wrote:
Mon Jun 22, 2020 12:21 pm
Could you paste the complete error message so that we know which symbol is unknown?
Here it is:
Pass 1...
helloworld.asm:137: ERROR: Unknown symbol "-lda.l".

User avatar
dougeff
Posts: 2735
Joined: Fri May 08, 2015 7:17 pm
Location: DIGDUG
Contact:

Re: Unknown symbol...

Post by dougeff » Sun Jul 12, 2020 5:42 pm

This code is for the WLA-DX assembler. Is that what you are using?
nesdoug.com -- blog/tutorial on programming for the NES

LucianoTheWindowsFan
Posts: 28
Joined: Mon Jun 22, 2020 9:39 am

Re: Unknown symbol...

Post by LucianoTheWindowsFan » Sun Jul 12, 2020 5:51 pm

dougeff wrote:
Sun Jul 12, 2020 5:42 pm
This code is for the WLA-DX assembler. Is that what you are using?
Yup, I use the WLA-DX assembler.

User avatar
dougeff
Posts: 2735
Joined: Fri May 08, 2015 7:17 pm
Location: DIGDUG
Contact:

Re: Unknown symbol...

Post by dougeff » Sun Jul 12, 2020 6:25 pm

funny, how it seems to merge the label "-" and the opcode "lda.l" in that error message

maybe you accidentally deleted the whitespace between them. add a space or tab there, line 137, between the - and lda.l
nesdoug.com -- blog/tutorial on programming for the NES

LucianoTheWindowsFan
Posts: 28
Joined: Mon Jun 22, 2020 9:39 am

Re: Unknown symbol...

Post by LucianoTheWindowsFan » Sun Jul 12, 2020 6:45 pm

dougeff wrote:
Sun Jul 12, 2020 6:25 pm
funny, how it seems to merge the label "-" and the opcode "lda.l" in that error message

maybe you accidentally deleted the whitespace between them. add a space or tab there, line 137, between the - and lda.l
there was a space, but didn't work, so it seems like this was useless as this code dates to 2005.

LucianoTheWindowsFan
Posts: 28
Joined: Mon Jun 22, 2020 9:39 am

Re: Unknown symbol...

Post by LucianoTheWindowsFan » Mon Jul 20, 2020 9:50 am

Now works with SNES_10 but when I use different music and SFX, the SFX didn't play.

User avatar
dougeff
Posts: 2735
Joined: Fri May 08, 2015 7:17 pm
Location: DIGDUG
Contact:

Re: Unknown symbol...

Post by dougeff » Mon Jul 20, 2020 9:47 pm

Make sure you mark each SFX with a check in the song list. Also, you need to have unused channels in the song that is playing.
nesdoug.com -- blog/tutorial on programming for the NES

Post Reply