Not receiving email notifications

Discussion about the site's wiki, including bugs/issues encountered

Moderator: Moderators

Post Reply
tepples
Posts: 21746
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Not receiving email notifications

Post by tepples » Sun Jun 21, 2015 8:10 pm

Wiki is having the same email problems as forums.

User avatar
Memblers
Site Admin
Posts: 3769
Joined: Mon Sep 20, 2004 6:04 am
Location: Indianapolis
Contact:

Re: Not receiving email notifications

Post by Memblers » Sun Jun 21, 2015 10:18 pm

Not sure if I have admin access on the wiki, I logged in but couldn't find any email settings. Once I know how to get to it, I can set it up with the gmail account the forum is using. If not, I can give the info to you (Google will probably call it 'suspicious activity' if you log in though), or one of us can create a separate gmail address to use for the wiki.

So far, email notification seems to be working OK for the forum.

tepples
Posts: 21746
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Not receiving email notifications

Post by tepples » Sun Jun 21, 2015 10:50 pm

E-mail settings are in LocalSettings.php, and you need shell or SFTP access to edit that.

User avatar
AMIGrAve
Posts: 6
Joined: Fri Nov 13, 2015 2:43 am

Re: Not receiving email notifications

Post by AMIGrAve » Fri Apr 08, 2016 6:34 am

Here's the error I received after creating an account:

Code: Select all

Welcome, AMIGrAve!
Nesdev wiki could not send your confirmation mail. Please check your email address for invalid characters.

Mailer returned: Failed to connect to ac1.foxwebstores.com:25 [SMTP: Failed to connect socket: No route to host (code: -1, response: )]

Your account has been created. You can change your Nesdev wiki preferences if you wish.

Return to Category:Mappers with scanline IRQs.
Image

tepples
Posts: 21746
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Not receiving email notifications

Post by tepples » Thu May 26, 2016 11:02 pm

In [url=http://forums.nesdev.com/viewtopic.php?p=171761#p171761]this post[/url], rainwarrior wrote:(It might help if there was someone else able to approving new users and moderating the wiki, though; you are a bottleneck there. Same goes for the forum itself.)
The emailconfirmed mechanism is supposed to do this, but it's broken because the wiki isn't configured with the correct SMTP endpoint and credentials. Should I try to dig the credentials out of the phpBB configuration and apply it to MediaWiki?

User avatar
Memblers
Site Admin
Posts: 3769
Joined: Mon Sep 20, 2004 6:04 am
Location: Indianapolis
Contact:

Re: Not receiving email notifications

Post by Memblers » Thu May 26, 2016 11:14 pm

Yes, let's do that.

tepples
Posts: 21746
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Not receiving email notifications

Post by tepples » Fri May 27, 2016 3:34 pm

After receiving new credentials from Memblers and applying changes to $wgSMTP in LocalSettings.php, I have confirmed that email from the wiki is working again. If you registered within the past year but were not able to confirm your address, request confirmation again.

tepples
Posts: 21746
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Not receiving email notifications

Post by tepples » Thu Jan 05, 2017 6:27 pm

...aaaaaand it's busted.

Around 8:20 PM US EST (2017-01-06T01:20Z), Muramasa in #nesdev tried a couple times to sign up. But each time, he got a blank page. I tried "create via email", which creates the account with a random password and mails it to the user, but that also produced a blank page and no new user account. I had him try it again with no email address, and it worked.

So mail from the wiki must be broken again.

User avatar
Memblers
Site Admin
Posts: 3769
Joined: Mon Sep 20, 2004 6:04 am
Location: Indianapolis
Contact:

Re: Not receiving email notifications

Post by Memblers » Fri Jan 06, 2017 10:02 pm

I can see that the email for the forums is still working, it must be that something the wiki depends on has been updated or changed.

User avatar
B00daW
Posts: 584
Joined: Thu Jan 03, 2008 1:48 pm

Re: Not receiving email notifications

Post by B00daW » Wed Sep 06, 2017 5:24 pm

WhoaMan is usually available on IRC. Has he given us a reply on this?

tepples
Posts: 21746
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Not receiving email notifications

Post by tepples » Wed Jan 23, 2019 8:54 am

A year later and still broken.

A user has sent me a PM that he has forgotten the credentials for his wiki account. I've located the most likely username, but until mail from the wiki works again, I can't send a password reset to the address that he has on file, or to any other users for that matter.

Post Reply