It is currently Sat Jun 24, 2017 8:40 am

All times are UTC - 7 hours





Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sat Mar 11, 2017 2:07 pm 
Offline
User avatar

Joined: Sun Jan 22, 2012 12:03 pm
Posts: 5306
Location: Canada
I was trying to edit the wiki earlier, and it wouldn't let me save an edit. It said there was a loss of session data and suggested I logout and login. After logging out I was not able to log back in, giving this error:
Attachment:
nesdev_wiki_login_error_cookies.png
nesdev_wiki_login_error_cookies.png [ 8.9 KiB | Viewed 335 times ]


On Firefox I can log in to the Wiki and edit it still. On Chrome I can no longer log in (though logout/login for the forum is perfectly fine). Is there some weird Chrome keycombo that disables cookies for one subdomain that I accidentally pressed?

Anyone else have this problem (and hopefully knows how to fix it)?


Top
 Profile  
 
PostPosted: Sat Mar 11, 2017 2:17 pm 
Offline

Joined: Sun Sep 19, 2004 11:12 pm
Posts: 18511
Location: NE Indiana, USA (NTSC)
Your screenshot does not include the address bar. Are you using https://wiki.nesdev.com/ or http://wiki.nesdev.com/? Is there an icon of a cookie with an X on it at the left side?

Have you followed the steps in the section "Make exceptions for certain websites or domains" in the article "Clear, enable, and manage cookies in Chrome" and the article "Adjust website content settings"?

There could be an existing cookie interfering with MediaWiki's ability to log you out, keeping you in a state where some other cookie saved for that site overrides the cookie that the site is setting. I've seen this happen on a couple sites, particularly where both the cleartext HTTP and HTTPS versions of a site try to set a cookie, and where both the site with and without the www try to set a cookie. Deleting all cookies associated with the wiki.nesdev.com hostname would clear this up.


Top
 Profile  
 
PostPosted: Sat Mar 11, 2017 2:21 pm 
Offline
User avatar

Joined: Sun Jan 22, 2012 12:03 pm
Posts: 5306
Location: Canada
So, the solution was apparently doing this in Chrome:

... > More tools > Clear browsing data

I nuked browsing history, download data, cookies/site data, and image cache, but probably only cookies mattered.

(Unrelated issue: apparently LastPass can't correctly populate the password field either for the wiki login. It fills it with I don't know what so I have to manually paste my password in there.)

Bleh, now I get to log back into everything. :) :| :(


Top
 Profile  
 
PostPosted: Thu Apr 06, 2017 11:51 am 
Offline
User avatar

Joined: Sun Jan 22, 2012 12:03 pm
Posts: 5306
Location: Canada
Okay, so this has happened to me a second time. I really hope this doesn't become a common recurrence.

Here's the less nuclear fix:

In Chrome go to...

1. Settings
2. Show advanced settings (at bottom), or type "cookies" in the settings search.
3. Privacy > Content Settings...
4. All cookies and site data
5. Search for nesdev and delete your cookies for wiki.nesdev.com


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group