Page 1 of 1

Can't login, complains cookies are disabled? (Chrome)

Posted: Sat Mar 11, 2017 2:07 pm
by rainwarrior
I was trying to edit the wiki earlier, and it wouldn't let me save an edit. It said there was a loss of session data and suggested I logout and login. After logging out I was not able to log back in, giving this error:
nesdev_wiki_login_error_cookies.png
nesdev_wiki_login_error_cookies.png (8.9 KiB) Viewed 6227 times
On Firefox I can log in to the Wiki and edit it still. On Chrome I can no longer log in (though logout/login for the forum is perfectly fine). Is there some weird Chrome keycombo that disables cookies for one subdomain that I accidentally pressed?

Anyone else have this problem (and hopefully knows how to fix it)?

Re: Can't login, complains cookies are disabled? (Chrome)

Posted: Sat Mar 11, 2017 2:17 pm
by tepples
Your screenshot does not include the address bar. Are you using https://wiki.nesdev.com/ or http://wiki.nesdev.com/? Is there an icon of a cookie with an X on it at the left side?

Have you followed the steps in the section "Make exceptions for certain websites or domains" in the article "Clear, enable, and manage cookies in Chrome" and the article "Adjust website content settings"?

There could be an existing cookie interfering with MediaWiki's ability to log you out, keeping you in a state where some other cookie saved for that site overrides the cookie that the site is setting. I've seen this happen on a couple sites, particularly where both the cleartext HTTP and HTTPS versions of a site try to set a cookie, and where both the site with and without the www try to set a cookie. Deleting all cookies associated with the wiki.nesdev.com hostname would clear this up.

Re: Can't login, complains cookies are disabled? (Chrome)

Posted: Sat Mar 11, 2017 2:21 pm
by rainwarrior
So, the solution was apparently doing this in Chrome:

... > More tools > Clear browsing data

I nuked browsing history, download data, cookies/site data, and image cache, but probably only cookies mattered.

(Unrelated issue: apparently LastPass can't correctly populate the password field either for the wiki login. It fills it with I don't know what so I have to manually paste my password in there.)

Bleh, now I get to log back into everything. :) :| :(

Re: Can't login, complains cookies are disabled? (Chrome)

Posted: Thu Apr 06, 2017 11:51 am
by rainwarrior
Okay, so this has happened to me a second time. I really hope this doesn't become a common recurrence.

Here's the less nuclear fix:

In Chrome go to...

1. Settings
2. Show advanced settings (at bottom), or type "cookies" in the settings search.
3. Privacy > Content Settings...
4. All cookies and site data
5. Search for nesdev and delete your cookies for wiki.nesdev.com