Famicom : Wavy artefacts on top of screen?

Discuss technical or other issues relating to programming the Nintendo Entertainment System, Famicom, or compatible systems.

Moderator: Moderators

Post Reply
User avatar
bleubleu
Posts: 92
Joined: Wed Apr 04, 2018 7:29 pm
Location: Montreal, Canada

Famicom : Wavy artefacts on top of screen?

Post by bleubleu » Fri Jul 31, 2020 5:31 am

Hi!

I recently got myself a FDS RAM adapter + FDS stick. Everything works great except a few rare games where a certain fraction of the top of the screen is wavy or misaligned.

For example, here in the FDS version of Zelda, up to about 1/3 of the screen is misaligned. Some screens of the zelda map are perfect, some are anywhere in between.

FDS.jpg

I don't have enough of a Famicom game library to tell if the issue is on the Famicom itself, or the FDS. Famicom is AV modded if that matters.

IRQ issue? Sprite zero issue? Opinions are welcome!

-Mat

Sorry if its not directly a "dev" question, but i am using this system for development.

User avatar
Quietust
Posts: 1567
Joined: Sun Sep 19, 2004 10:59 pm
Contact:

Re: Famicom : Wavy artefacts on top of screen?

Post by Quietust » Fri Jul 31, 2020 5:45 am

A display issue like that can really only come from two places:
1. the game itself performing carefully-timed adjustments to the horizontal scroll register
2. the display device (i.e. your TV) failing to synchronize to the video signal, typically due to using the "blacker than black" palette value 0x0D but potentially also due to miscalibration

I strongly suspect that the latter case is what you are experiencing.
Last edited by Quietust on Sat Aug 01, 2020 4:56 pm, edited 1 time in total.
Quietust, QMT Productions
P.S. If you don't get this note, let me know and I'll write you another.

Fiskbit
Posts: 121
Joined: Sat Nov 18, 2017 9:15 pm

Re: Famicom : Wavy artefacts on top of screen?

Post by Fiskbit » Fri Jul 31, 2020 1:42 pm

Zelda FDS correctly uses $0F as its black color. Is this issue only occurring in games with large black areas? Could the Famicom be outputting too low a voltage?

lidnariq
Posts: 9500
Joined: Sun Apr 13, 2008 11:12 am
Location: Seattle

Re: Famicom : Wavy artefacts on top of screen?

Post by lidnariq » Fri Jul 31, 2020 1:59 pm

bleubleu wrote:
Fri Jul 31, 2020 5:31 am
Famicom is AV modded if that matters.
I'd double-check the AV mod.

The top scanlines for the status bar are shearing to the left: the TV is not finding the sync pulse and is drawing scanlines a little too late. The next scanlines where the game is drawing the playfield are shearing to the right: the TV is then finding the sync pulse, or is interpreting the active area as the sync pulse.

User avatar
bleubleu
Posts: 92
Joined: Wed Apr 04, 2018 7:29 pm
Location: Montreal, Canada

Re: Famicom : Wavy artefacts on top of screen?

Post by bleubleu » Sat Aug 01, 2020 9:20 am

Ok thanks guys.

That already gives me a couple of hints on what to check.

Ill run some more test to see a pattern where this happens where there top is mostly black.

I'll also try to double check the voltages, i am running off a 9V ac adapter (as opposed to 10V that it should be) although everything should get regulated to 5V internally by the 7805. Maybe something is off here too. Also im thinking maybe the RCA cable im using is wayyyyy to long maybe.

Anyhow. Ill report back when i have troubleshooted a bit more.

-Mat

User avatar
zoinknoise
Posts: 31
Joined: Fri Mar 04, 2016 9:43 am
Location: Ice Cream Island

Re: Famicom : Wavy artefacts on top of screen?

Post by zoinknoise » Sat Aug 01, 2020 1:56 pm

i can tell you from firsthand experience that some CRT's, for whatever reason, turn their noses up at a composite-modded RF Fami. i still have no idea why.

i've got one of the last "regular" Trinitrons (from 1999, before the flatscreen models) and after modding TWO Famicoms with composite and seeing them work fine on my 55" LED TV, when plugged into my Trinitron they came up in black and white no matter what i did. i changed the master crystal and everything, nothing helped.

meanwhile, my AV Famicom and NES frontloader come up in color, thru the very same composite jack on the very same TV. it was really driving me crazy, i had to drop the whole idea.

i ended up getting satisfactory results by plugging a coax cable straight from the Fami to the TV, (no RF switch, just an RCA adapter on the console end) turning on "cable mode", and tuning to channel 96. excellent picture quality, hardly distinguishable from my AV Fami.

User avatar
Dwedit
Posts: 4329
Joined: Fri Nov 19, 2004 7:35 pm
Contact:

Re: Famicom : Wavy artefacts on top of screen?

Post by Dwedit » Sat Aug 01, 2020 10:35 pm

Voltage levels okay? I wonder if an oscilloscope could show anything off with the signal.
Here come the fortune cookies! Here come the fortune cookies! They're wearing paper hats!

Post Reply