It is currently Sat Oct 21, 2017 12:41 pm

All times are UTC - 7 hours





Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Project S-11 sound/music
PostPosted: Thu May 31, 2012 11:20 am 
Offline
User avatar

Joined: Thu Jan 03, 2008 1:48 pm
Posts: 540
In many of the songs within the Project S-11 soundtrack it seems like there is a buzzing or a staticky noise coming from the WAV channel. It doesn't happen all the time and other times the noise is drowned out by the other channels and is not noticed. I'm using kingshriek's rip for reference.

I may attempt to use BGB and the GB ROM file for debugging shortly to attempt to figure out what's happening. I've not done anything with Z80 yet and am not familiar with the differences of Z80 versus GBZ80; but this may prove an interesting learning ground.

Since this game and rip has been around for quite some time, has anybody else noticed this and figured out what the buzzing noise is coming from? If so, potentially we could patch the GBS and the ROM itself since it's rather distracting from the beauty of the music.


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 31, 2012 2:35 pm 
Offline

Joined: Sat Jan 23, 2010 11:41 pm
Posts: 1161
GB CPU is inbetween of 8080 and Z80, closer to 8080 with few things from Z80 and few extras. So if you know either of those, it'll be easy for you.


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 31, 2012 10:34 pm 
Offline

Joined: Tue Jan 31, 2006 5:43 am
Posts: 137
Are you using the latest NEZPlug++ for playback? I've compared the output with the latest BGB and I can't find any differences between them.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 01, 2012 8:14 am 
Offline
User avatar

Joined: Thu Jan 03, 2008 1:48 pm
Posts: 540
Knurek, I've used the latest NEZPlug++ and BGB. Compare Carillon and P5's engine capabilities together. It seems that Carillon has everything that P5 does, but P5 also has stereo. For some reason a lot of the poppnig in Project S-11 is coming from three things:

1.) In certain song banks it is setting setting FF1A's bit 7 off and on very rapidly every frame. (I suppose it is doing this so it can write to WAV RAM any time it pleases.) If I disable this routine the WAV RAM does not update in NEZPlug++ and KiGB, so the first few 4-bit nybbles repeat. However, in BGB the sample is updated even though the WAV channel has not been turned off. Also much of the buzzing and clicking is gone.

2.) The more complicated 4-bit samples are not very clean. I figure they could have been compressed and filtered a little bit more.

3.) The stereo controller FF25 is being set very rapidly... But I'm not certain if this could be creating buzzing or pops.

I'm not fully done debugging this, so these are my first impressions so far. I need to also whip out my flash cart and GBC later to really be sure to know how things should work.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group