nesdev.com
http://forums.nesdev.com/

need help repairing unidentified famiclone
http://forums.nesdev.com/viewtopic.php?f=22&t=16874
Page 1 of 1

Author:  maroonbrownie [ Fri Dec 29, 2017 12:52 pm ]
Post subject:  need help repairing unidentified famiclone

My famiclone was working up until a few years ago. i used to enjoy playing super mario on it with my parents. i pulled it out of storage recently. Marking I put on it years ago says 7.5V. So I got an adjustable power adapter so I can run it. My old (new to me) CRT TVs no longer seem to support it.

I pulled it apart to see if there was anything wrong. Some wires seemed to have come lose so i soldered them back (i didnt do a great job :| ). Anyway it still doesnt seem to work so I wanted to know if anyone has any advice or a similar one so I can compare pics and see if the connections are right.

Any advice on what might need to be done to connect it to a tv? The famiclone has an ac port and the red yellow white composite ports.

Any advice is appreciated!

https://imgur.com/a/P7tjv

Author:  Airbits [ Fri Jan 19, 2018 3:25 pm ]
Post subject:  Re: need help repairing unidentified famiclone

Is there games built in the system? If so how many, and what are they? Also, Can you send more pics of the motherboard?

Author:  Fisher [ Fri Jan 19, 2018 3:44 pm ]
Post subject:  Re: need help repairing unidentified famiclone

For what I could see on the pictures, the wire before the pad that there's no wire looks broken.
Also, I could not see clearly what that missing wire would do, but seems to be the same function as the last wire.
Try to do a continuity check on these wires.
That's all I can think for now, sorry...

Page 1 of 1 All times are UTC - 7 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/