Help - Game froze during save on SNES console, fine on Super NT

A place that you can discuss reproduction of classic titles or "licensed-for-reproduction" homebrew for personal use.

Moderators: B00daW, Moderators

Forum rules
1. NO BLATANT PIRACY. This includes reproducing homebrew less than 10 years old, with the exception of free software.
2. No advertising your reproductions, with the exception of free software.
3. Be nice. See RFC 1855 if you aren't sure what this means.
Post Reply
GreenDevil
Posts: 1
Joined: Sat Aug 08, 2020 1:14 pm

Help - Game froze during save on SNES console, fine on Super NT

Post by GreenDevil » Mon Sep 07, 2020 9:47 am

Hi there - new to the community and hoping to find some help here where my researching could not.


Background
I just finished making a Chrono Trigger repro for myself (original rom no hacks so 32 bit). PCB was ordered from Muramasa Entertainment and I populated it myself using parts that have worked on other boards in the past without issue. I'm using an M27C322 eprom.

Here's a link to the board - https://www.muramasaentertainment.com/p ... dip42-4mb/


Problem
Game ran fine on original hardware and Super NT when I tested it. I went to save on an original SNES and it froze. Game would not load on SNES after that, just black screen. I then tried the cart on a Suprt NT without any problems. It even had my save file (that caused the freezing) in the SRAM and I was able to load and play. I was even able to save to SRAM on Super NT with no freezing and continue to play. Game still does not work original SNES (other games do).


My troubleshooting
I checked all my solder joints and everything seems fine. The only questionable one was a bridge to set the SRAM size (it's 8kb per uCon64). I am using a 6264 SRAM, all bridges set to hirom and SRAM bridged to battery instead of VCC. I also checked all my components and am confident that I have everything populated with the correct parts and orientation. Checksum was also repaired and is OK.

I'm guessing something happened to the CIC chip when I saved that first time? Any ideas?

soniccd123
Posts: 9
Joined: Sat Jun 27, 2020 12:01 pm

Re: Help - Game froze during save on SNES console, fine on Super NT

Post by soniccd123 » Wed Sep 16, 2020 8:02 pm

GreenDevil wrote:
Mon Sep 07, 2020 9:47 am
Problem
Game ran fine on original hardware and Super NT when I tested it. I went to save on an original SNES and it froze. Game would not load on SNES after that, just black screen. I then tried the cart on a Suprt NT without any problems. It even had my save file (that caused the freezing) in the SRAM and I was able to load and play. I was even able to save to SRAM on Super NT with no freezing and continue to play. Game still does not work original SNES (other games do).
Just to clarify, you did try to program other games on the EPROM chip after the problems started? did they loaded fine?

Post Reply