Another new user with annoying questions! (Kazzo Programmer)

A place that you can discuss reproduction of classic titles or "licensed-for-reproduction" homebrew for personal use.

Moderators: B00daW, Moderators

Forum rules
1. NO BLATANT PIRACY. This includes reproducing homebrew less than 10 years old, with the exception of free software.
2. No advertising your reproductions, with the exception of free software.
3. Be nice. See RFC 1855 if you aren't sure what this means.
NYMike
Posts: 120
Joined: Wed Jul 01, 2015 3:21 pm

Re: Another new user with annoying questions! (Kazzo Program

Post by NYMike » Sun Aug 23, 2015 12:39 pm

Having a bit of trouble getting Breath of Fire II and the fan patch to work correctly. Digging around this site though it looks like others have been able to get around the issue I am having. I can burn BoF II and the patch, they both start up just fine, but I get the new game error loop where it will not save the game. I am more interested in getting the fan patch to work, anyone able to assist?

I start off with Breath Of Fire II (U) [!].zip , I then use Ucon to strip the header. I then patch the file with ips. It then makes the file an even 4mb. I have tried a few different options, I have tried strip header, fix checksum, crack, slowRom fix. Nothing seems to get around this issue. I am able to get past this issue on both the normal rom and the homemade version on zsnes. Has anyone else been able to burn the fan made version to a INL 4mb flash cart and get past the infinite loop error? Thanks for any continual help, and hopefully this is a quick fix since it seems others have been able to get around it.

lidnariq
Posts: 9792
Joined: Sun Apr 13, 2008 11:12 am
Location: Seattle

Re: Another new user with annoying questions! (Kazzo Program

Post by lidnariq » Sun Aug 23, 2015 1:41 pm

NYMike wrote:zsnes
You should test with bsnes or its forks; ZSNES and SNES9x are phenomenally inaccurate.

NYMike
Posts: 120
Joined: Wed Jul 01, 2015 3:21 pm

Re: Another new user with annoying questions! (Kazzo Program

Post by NYMike » Sun Aug 23, 2015 2:23 pm

Tested in bsnes it works on my pc as well as zsnes. For whatever reason, when I burn the rom to a INL cart, it screws with the ability to create game data. I am guessing that it is something that I am doing wrong on my end and would love to know if someone else has been able to get this working. The patch looks pretty impressive (to me at least).

NYMike
Posts: 120
Joined: Wed Jul 01, 2015 3:21 pm

Re: Another new user with annoying questions! (Kazzo Program

Post by NYMike » Sun Aug 30, 2015 10:07 am

OK progress! I have officially been able to burn the Fan translation of Breath of Fire 2 with both the Japanese song intro as well as Into the Fire and the Flames found at http://www.romhacking.net/translations/1384/ onto a 4mb INL board. It plays on both a SNES as well as a Retro Duo Portable as well. The issue was not burning it, it was having to do several fixes in Ucon64. So far most games just needed 1 fix with Ucon64, so I would chalk this up to me being inexperienced in the whole process still.

tepples
Posts: 22090
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Another new user with annoying questions! (Kazzo Program

Post by tepples » Sun Aug 30, 2015 10:41 am

NYMike wrote:I have officially been able to burn the Fan translation of Breath of Fire 2 with both the Japanese song intro as well as Into the Fire and the Flames found at http://www.romhacking.net/translations/1384/ onto a 4mb INL board.
Is that really "Through the Fire and Flames" (tippity-tappity tippity-tappity tippity-tappity HOPOs, then suddenly strum-like-my-life-depends-on-it) or something else?

NYMike
Posts: 120
Joined: Wed Jul 01, 2015 3:21 pm

Re: Another new user with annoying questions! (Kazzo Program

Post by NYMike » Mon Aug 31, 2015 3:44 pm

Not my video, but its still the video for the beginning of the game. https://www.youtube.com/watch?v=-S2-NMyJgGQ I went out and bought a original copy of the game off of Epay and I do admit, the translation makes the game better in my eyes.

NYMike
Posts: 120
Joined: Wed Jul 01, 2015 3:21 pm

Re: Another new user with annoying questions! (Kazzo Program

Post by NYMike » Sat Sep 05, 2015 9:31 am

Starting to get a build up on old boards. Ironically I get these sports game boards for the cheapest, and they are the most sought after for reproduction. I found this site http://www.gamereproductions.com/ that gives credit for complete carts like these. Is this my best route to go, or does anyone have a suggestion that I could take to reuse the old parts?
DSCN1214.JPG

NYMike
Posts: 120
Joined: Wed Jul 01, 2015 3:21 pm

Re: Another new user with annoying questions! (Kazzo Program

Post by NYMike » Sat Sep 26, 2015 5:03 pm

Added even more games to the success list. I also got my hands on some 8mb and a 12 mb cart. Time for some Chrono Trigger remakes and Star Ocean. If anyone has any tips on those, feel free to school me!

NYMike
Posts: 120
Joined: Wed Jul 01, 2015 3:21 pm

Re: Another new user with annoying questions! (Kazzo Program

Post by NYMike » Tue Sep 29, 2015 6:10 pm

Still having issues with hi roms on inl 8 and 12 mb boards. Anyone able to tell me if I am doing these steps right?

1. Remove header
2. Test in Bsnes (works)
3. Split file 4mb and 2mb
4. Select 2nd half of file first and recombine file
5. test in Bsnes (works)
6. Erase cart in Retro-Prog, select 8mb board
7 Still fails.

Any help would be appreciated. I know the boards work because lo roms work on these boards but hi does not.

Gered
Posts: 9
Joined: Mon Mar 16, 2015 11:03 am

Re: Another new user with annoying questions! (Kazzo Program

Post by Gered » Tue Sep 29, 2015 6:27 pm

So, I just recently made myself a DQ3 repro. It's a 6 MB ROM file, so requires use of the 8 MB INL board. Basically, I padded the file to 8MB, then in a hex editor I swapped the first and last 4MB around, and then duplicated the first 2MB (which was originally the last 2MB before I swapped the halves in the file) so it appears twice at the start of the file.

A diagram to (hopefully) more clearly illustrate what I did:

Code: Select all

Original ROM file layout:

0   2   4   6   8 MB
+---+---+---+---+
| A | B | C |   |
+---+---+---+---+

After fixing up the layout in a hex editor:

0   2   4   6   8 MB
+---+---+---+---+
| C | C | A | B |
+---+---+---+---+
Also, when I did this I just assumed the "fixed" ROM wouldn't work in any emulator and just flashed it to my INL board and it worked, so all good. But I just now tried opening the ROM I flashed to my INL board in bsnes, and as I expected it didn't work. Not sure why yours was working in an emulator after editing the file layout, that seems weird to me.

NYMike
Posts: 120
Joined: Wed Jul 01, 2015 3:21 pm

Re: Another new user with annoying questions! (Kazzo Program

Post by NYMike » Tue Sep 29, 2015 6:39 pm

Honestly I am stepping out of my limited experience with the 8mb boards and was just recommended a new program to try today. It was free file splitter (http://www.filesplitter.org/), so it is possible that when I split the file, and recombined it that it did absolutely nothing but put the 1st and 2nd half together in the same exact order.

sherpahigh
Posts: 2
Joined: Wed Sep 30, 2015 10:37 am

Re: Another new user with annoying questions! (Kazzo Program

Post by sherpahigh » Wed Sep 30, 2015 10:50 am

edit: will report back when i try some more things

sherpahigh
Posts: 2
Joined: Wed Sep 30, 2015 10:37 am

Re: Another new user with annoying questions! (Kazzo Program

Post by sherpahigh » Wed Sep 30, 2015 4:05 pm

NYMike I sent you a PM.

NYMike
Posts: 120
Joined: Wed Jul 01, 2015 3:21 pm

Re: Another new user with annoying questions! (Kazzo Program

Post by NYMike » Thu Oct 01, 2015 10:40 am

So I am having an issue with an 8mb board still. Working with a member in private messages we have a copy of Crono Trigger Crimson echoes. On one 8mb board the game runs fine without issue. On
the second board if I try to enter the menu to save the game on a SNES it crashes. If I try playing it on a Retro Duo Portable, it will enter the save screen, but the text is a bit garbled as well as the game save is very off. Instead of saving in the chapter prologue, it saves as the last chapter with 99 saves and 99:59 hours played. No matter how many times I erase the board, it still gives me this error. I have tried pulling out the battery and letting it sit over night. Anyone have any suggestions on how to fully purge a 8mb inl cart? I get the feeling that there is some remnant data even after an erase.

Solved? So it seems like there is a small imperfection with this board. By itself it has issues, in the snap connect holder it has issues, but in a regular cart with security bits cranked down, so far it plays fine.

NYMike
Posts: 120
Joined: Wed Jul 01, 2015 3:21 pm

Re: Another new user with annoying questions! (Kazzo Program

Post by NYMike » Sun Oct 11, 2015 1:01 pm

Added 8mb and 12mb games to the list. Special thanks to Gered and sherpahigh for help in private messages as well as multiple testings and findings with different software that resulted in some interesting errors.

Post Reply