SNES Repro Help: 12mbit ROM

A place that you can discuss reproduction of classic titles or "licensed-for-reproduction" homebrew for personal use.

Moderators: B00daW, Moderators

Forum rules
1. NO BLATANT PIRACY. This includes reproducing homebrew less than 10 years old, with the exception of free software.
2. No advertising your reproductions, with the exception of free software.
3. Be nice. See RFC 1855 if you aren't sure what this means.
Post Reply
pozzumgee
Posts: 1
Joined: Tue Aug 18, 2015 8:15 pm

SNES Repro Help: 12mbit ROM

Post by pozzumgee » Tue Aug 18, 2015 8:19 pm

Hello all!
I am trying to make a copy of King of Demons. I got a translated rom by Aeon Genesis, here are the details:

LoRom
12mbit
No SRAM
No header

I used Lunar Expand to expand the rom to 16mbit, and then used Wasabi to split into two files and swapbin. I installed it on a board that has 2 mask roms but no sram (dennis the menace). When I turned it on, the publisher screen came up, but then the title screen wouldn't load at all. Coincidentally, this is also what happens if you just try to run Bin_01 in SNES9X: after the publisher screen, the emulator crashes. I was under the impression that once a game had been swap-binned, it wouldn't run in an emulator at all.

Did I do this wrong? Should I have split/swap-binned the file first and THEN expanded the 2nd ROM? If this is the case, is the first rom (bin_01) still good?

Also, first time poster. Apologies if this is the wrong place for this. Thanks!

darknezz19
Posts: 71
Joined: Wed Aug 26, 2009 8:28 am

Re: SNES Repro Help: 12mbit ROM

Post by darknezz19 » Thu Aug 20, 2015 9:53 pm

Yep wrong section, there's a /reproduction section for this stuff now. Most people around here are nice enough and don't really care about something like this though.

I don't think swapbin is able to handle 2mb swaps properly. I could be wrong here but anything thats over 2MB wont swap properly even if it's split into two 1mb files first. Try it without swapbin and do the extra wiring.

Post Reply