It is currently Sat Aug 24, 2019 10:18 am

All times are UTC - 7 hours



Forum rules


1. NO BLATANT PIRACY. This includes reproducing homebrew less than 10 years old, with the exception of free software.
2. No advertising your reproductions, with the exception of free software.
3. Be nice. See RFC 1855 if you aren't sure what this means.



Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Wed May 04, 2016 10:00 am 
Offline

Joined: Fri Jul 04, 2014 2:34 pm
Posts: 344
I'm trying to make a repro of this game and according to the pictures from Bootgod, the original cart uses a 74'161 and 74'138.

I traced down all connections I could find and came up with this:
Code:
               74'161

               .--\/--.
         +5V --|01  16|-- +5V
     PRG R/W --|02  15|-- NC
      PRG D0 --|03  14|-- PRG A15
      PRG D1 --|04  13|-- PRG A16
      PRG D2 --|05  12|-- CHR A13
      PRG D3 --|06  11|-- CHR A14
         GND --|07  10|-- GND
         GND --|08  09|-- '138 Pin 7
               `------'

               74'138

               .--\/--.
     PRG A12 --|01  16|-- +5V
     PRG A13 --|02  15|-- NC
     PRG A14 --|03  14|-- NC
          NC --|04  13|-- NC
     PRG R/W --|05  12|-- NC
     PRG /CE --|06  11|-- NC
  '161 Pin 9 --|07  10|-- NC
         GND --|08  09|-- NC
               `------'


So I tried remaking that game on a CN-ROM board, since it already has a 74'161 on board.

This is what I did:

Desoldered original CHR, PRG ROM as well as 74'161.

Split Crime Busters into CHR (27c256) and PRG (27c040, didn't have a 27c010).

Soldered in the CHR directly (A13 and A14) go to the 74'161 anyway and are present, which is good.

For PRG I bend up pins 1,2,3,22,24,30,31,32
Pin 1 is NC
Pin 2 goes to 74'161 pin 13 (A16)
Pin 3 goes to 74'161 pin 14 (A15)
Pin 22 goes to hole 24 (PRG ROM /CE)
Pin 24 goes to GND (/OE)
Pin 30 and 31 are NC
Pin 32 goes to hole 28 (VCC)

A14 was not connected directly to the connector, I changed that, too.

Tried connecting pin 30 (A17) to VCC as well, no difference.

For the 74'161 I bend up pins 2,5,6,9,11,12,13 and 14. All other pins connect to the board.

The game stays black. Anyone know what could be wrong?

Also, the original board has a 4.7k Ohm resistor if I'm not wrong and a capacitor. What could they be used for? Are they neccessary? Thanks!


Attachments:
back.jpg
back.jpg [ 51.27 KiB | Viewed 2944 times ]
front.jpg
front.jpg [ 57.63 KiB | Viewed 2944 times ]


Last edited by Ice Man on Sun May 08, 2016 7:48 am, edited 1 time in total.
Top
 Profile  
 
PostPosted: Wed May 04, 2016 10:35 am 
Offline

Joined: Sun Apr 13, 2008 11:12 am
Posts: 8537
Location: Seattle
I could have sworn I'd previously traced this... oh, yes, I had.

'138 pin 4 is shorted to pin 5. Leaving pin 4 floating could explain what you're seeing.


Top
 Profile  
 
PostPosted: Wed May 04, 2016 11:25 am 
Offline

Joined: Fri Jul 04, 2014 2:34 pm
Posts: 344
Okay, so, I forgot there was a solder bridge that connects PRG A14 to VCC as well.
I removed it and now the game boots somewhere in a level and glitches.

Shorting pin 4 and 5 results in a black screen.

However, when connecting A17 to VCC I get a Game Over screen (frozen).

Sometimes I get the title screen and most of the time black screen.

I'm confused with this cart.


Top
 Profile  
 
PostPosted: Wed May 04, 2016 11:39 am 
Offline

Joined: Sun Apr 13, 2008 11:12 am
Posts: 8537
Location: Seattle
Ice Man wrote:
Also, the original board has a 4.7k Ohm resistor [...] and a capacitor. What could they be used for? Are they neccessary?
Quite possibly. I bet they connect to 74'161 /CLEAR, so that the register starts up in bank 0.


Top
 Profile  
 
PostPosted: Wed May 04, 2016 11:54 am 
Offline

Joined: Fri Jul 04, 2014 2:34 pm
Posts: 344
That could explain why the game messed up so much.
I dumped it using GNROM Script with Kazzo. First x4000 bytes were equal, x100 bytes difference and equal again compared to the original. Didn't check the full PRG ROM data though. I'm sure there's more differences. Either way, I desoldered everything for now and will try again tomorrow as it's getting too dark to solder properly.

P.S. The game was working fine in an emulator once dumped until the stage select screen (restarts, most likely caused by the bad dump/wiring).

Will update this topic once I have something new.

Also, looking closer to that resistor and capacitor this is what I come up with:

Code:
VCC > 4.7k Ohm > Capacitor- > Capacitor+ > Pin 1 of '161
                    v
                   GND


Now the question. What value is the capacitor?


Top
 Profile  
 
PostPosted: Wed May 04, 2016 12:00 pm 
Offline

Joined: Sun Apr 13, 2008 11:12 am
Posts: 8537
Location: Seattle
I barely think I see "0.1uF 50V" on the side

I'm kinda confused by a 0.1uF electrolytic, but.


Top
 Profile  
 
PostPosted: Thu May 05, 2016 4:37 am 
Offline

Joined: Fri Jul 04, 2014 2:34 pm
Posts: 344
This is indeed weird. I ordered some 4.7k ohm resistors to try it with one connected.

Also, I think my connection was wrong.

This is how it should be:

Code:
VCC > 4.7k Ohm > Capacitor- > Capacitor+ > VCC
                    v
                Pin 1 of '161


If I'm wrong or see this wrong, please correct me.


Top
 Profile  
 
PostPosted: Thu May 05, 2016 10:34 am 
Offline

Joined: Sun Apr 13, 2008 11:12 am
Posts: 8537
Location: Seattle
Both sides being connected to Vcc doesn't make sense.

I'm pretty certain that one side of the capacitor is connected to ground.

Ground - Capacitor - 74'161/CLEAR - Resistor - Vcc


Top
 Profile  
 
PostPosted: Fri May 06, 2016 5:21 am 
Offline

Joined: Fri Jul 04, 2014 2:34 pm
Posts: 344
So I'd need to disconnect 74'161 pin 1 from the CN-ROM board, since it's connected to VCC directly?

Then add the circuit to that pin and hope all goes well.

Hope the resistors will be delivered tomorrow.


Top
 Profile  
 
PostPosted: Sat May 07, 2016 11:10 am 
Offline

Joined: Fri Jul 04, 2014 2:34 pm
Posts: 344
SUCCESS!

This is the proper pinout to make this game boot and work!

Code:
                74'161

               .--\/--.
           * --|01  16|-- +5V
     PRG R/W --|02  15|-- NC
      PRG D0 --|03  14|-- PRG A15
      PRG D1 --|04  13|-- PRG A16
      PRG D2 --|05  12|-- CHR A13
      PRG D3 --|06  11|-- CHR A14
         GND --|07  10|-- GND
         GND --|08  09|-- '138 Pin 7
               `------'

                74'138

               .--\/--.
     PRG A12 --|01  16|-- +5V
     PRG A13 --|02  15|-- NC
     PRG A14 --|03  14|-- NC
          NC --|04  13|-- NC
     PRG R/W --|05  12|-- NC
     PRG /CE --|06  11|-- NC
  '161 Pin 9 --|07  10|-- NC
         GND --|08  09|-- NC
               `------'

*             Pin 1 of '161
                  v
    GND < 0.1uF < v > 4.7k > VCC


Since I'm using a 27c040 instead of 27c010 I had to connect
A17 to VCC
A18 to GND
in order to make it boot.

Connecting only A17 to VCC randomly crashed the game at the intro.

Thanks for the help lidnariq!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group