nesdev.com
http://forums.nesdev.com/

TKROM repro issues
http://forums.nesdev.com/viewtopic.php?f=28&t=15177
Page 1 of 1

Author:  flipsc87 [ Tue Nov 29, 2016 8:22 pm ]
Post subject:  TKROM repro issues

ok so i tried to make a Mario in some usual day on a TKROM, i split the roms using famirom onto two 27c2001 eproms. wired it like i would a TLROM. the donor was Base Wars. I did two of them the same way and all i get is a black screen. the rom works fine on my emulator and both donors were tested and cleaned.

Wiring is:
PRG
bend up pins 1,2,24,30,31
pin 2 to hole 24
pin 24 to gnd 16
pin 30 to hole 1

CHR
bend up pins 1,2,22,24,30,31
pin 2 to hole 24
pin 22 to hole 31
pin 24 to hole 2
(tried pin 1 to hole 30)

Author:  Ice Man [ Thu Dec 01, 2016 6:55 am ]
Post subject:  Re: TKROM repro issues

Did you use FamiROM to split the ROM properly into CHR and PRG (eventually expanded them) to be used on a 27c2001?

Mario in some usual day uses 256kb CHR and 256kb PRG.

Some EPROMs need PGM (Pin 31) set to low or high depending on the state. Try connecting it to GND or 5V.
Pin 1 (VPP) can be left untouched and unconnected as it is only used for programming.

Also EPROM Pin 30 of CHR has to be connected to pin 1 of CHR socket anyway.

Author:  flipsc87 [ Thu Dec 01, 2016 9:13 pm ]
Post subject:  Re: TKROM repro issues

Ice Man wrote:
Did you use FamiROM to split the ROM properly into CHR and PRG (eventually expanded them) to be used on a 27c2001?

Mario in some usual day uses 256kb CHR and 256kb PRG.

Some EPROMs need PGM (Pin 31) set to low or high depending on the state. Try connecting it to GND or 5V.
Pin 1 (VPP) can be left untouched and unconnected as it is only used for programming.

Also EPROM Pin 30 of CHR has to be connected to pin 1 of CHR socket anyway.



thanks for the help! so when you say pin 31 set to low or high is that on both prg and chr? i used famirom to split the rom and fill.

Page 1 of 1 All times are UTC - 7 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/