nesdev.com
http://forums.nesdev.com/

Reproduction Help
http://forums.nesdev.com/viewtopic.php?f=28&t=18558
Page 1 of 1

Author:  TanaPanda [ Mon Mar 04, 2019 7:07 pm ]
Post subject:  Reproduction Help

So. I have another thread discussing issues I am having with making a repo cart of Parallel Worlds. And I wanted to start this thread to help anyone having issues making their own games. I used to buy repo carts but then as i was getting into making them and doing research I noticed that a lot of people don't like the idea of someone making money off their hard work that was supposed to be enjoyed for free.

I may be new to making games but in the small amount of time i have been doing it I feel like i have done my fair amount of troubleshooting and wanted to offer this for people to ask for help as well as help me on my journey into this great hobby!

As further troubleshooting my failed zelda games I am currently writing a new game to a chip which I plan on putting into my failed games board to verify that my install was right and the software is bad. I am currently doing this so I will update this shortly with the results.

Author:  TanaPanda [ Mon Mar 04, 2019 8:15 pm ]
Post subject:  Re: Reproduction Help

Well I installed the new chip and no luck. The game doesn't work. I used a pre-translated rom so next I will try using the original and applying the patch myself. Also I am interested in knowing if anyone has gotten a game to work using a single 27c160 EPROM. I can confirm that 2 27c160 with a 139 decoder chip works and that 1 27c322 chip with 2 decoder chips also works. But i have yet to see the single 27c160 work by itself. So maybe before I try re-programming this chip. i'm going to load the same game onto 2 27c801 chips with a 139 decoder chip and see it that works.

Author:  X2Whiskey [ Wed Aug 14, 2019 4:55 pm ]
Post subject:  Re: Reproduction Help

Hello,

For motivation here's a pic of my working copy of Parallel Worlds. I get an odd feeling of satisfaction from the added heft of all the ceramic. Seriously, I do.

Image

It uses two 27C801's with a MAD-1. Unfortunately I can't help you with your main questions.

Attachments:
File comment: Parallel Worlds with two 27C801 EPROMs
IMG_1513.JPG
IMG_1513.JPG [ 2.2 MiB | Viewed 698 times ]

Author:  Ice Man [ Thu Aug 15, 2019 9:53 am ]
Post subject:  Re: Reproduction Help

Anything works if wired correctly.
1x27C160 in 8 bit mode
2x27C160 in 8 bit mode using a 74HC139 decoder
1x27C322 in 16 bit mode using either 74HC245+74HC139 or 2x74HC257

What exactly is the problem with your Parallel Worlds? Did you wire the EPROM correctly? Did you use SwapBin on the ROM?

Pictures and details would be appreciated.

Author:  TanaPanda [ Tue Sep 17, 2019 7:16 am ]
Post subject:  Re: Reproduction Help

The problem I have been having with Parallel Worlds is that when I play the game I get the music to start playing but nothing happens on the screen. I press start and what not to see if anything changes, like the game is working but i have no video but even that gets nothing. I have checked my wiring and everything looks right in the sense of how I wired it. You can see my wiring diagram in the other thread. On another note.

That copy you have looks sick. Did you make it yourself? If so where do you get the board that has 2 chip slots? is it a donor or a custom PCB you ordered? I have made one attempt at making a copy of Tales of Phantasia however the chips are super small compared to the ones I usually work with and I was unsuccessful in my attempt to put them onto the boards. I still have another set of ships I just haven't been brave enough to attempt it again.

Page 1 of 1 All times are UTC - 7 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/