TL-ROM Splatterhouse

A place that you can discuss reproduction of classic titles or "licensed-for-reproduction" homebrew for personal use.

Moderators: B00daW, Moderators

Forum rules
1. NO BLATANT PIRACY. This includes reproducing homebrew less than 10 years old, with the exception of free software.
2. No advertising your reproductions, with the exception of free software.
3. Be nice. See RFC 1855 if you aren't sure what this means.
FrankWDoom
Posts: 223
Joined: Mon Jan 23, 2012 11:27 pm

Re: TL-ROM Splatterhouse

Post by FrankWDoom » Sun Mar 15, 2020 9:35 am

No lift only 1,2,24 and reroute 2 and 24. The rest leave alone

Ice Man
Posts: 530
Joined: Fri Jul 04, 2014 2:34 pm

Re: TL-ROM Splatterhouse

Post by Ice Man » Mon Mar 16, 2020 3:19 am

You forgot pin 30 (A17). If he would connect it to hole 30 (VCC) it will be upper 128KB of EPROM only and makes the game unplayable if it's 256KB.
Pin 30 has to be connected to hole 1.

FrankWDoom
Posts: 223
Joined: Mon Jan 23, 2012 11:27 pm

Re: TL-ROM Splatterhouse

Post by FrankWDoom » Mon Mar 16, 2020 8:04 am

Prg rom is 128, pin 30 can be left alone to be fixed high as long as he's doubling correctly which he has indicated he is.

Ice Man
Posts: 530
Joined: Fri Jul 04, 2014 2:34 pm

Re: TL-ROM Splatterhouse

Post by Ice Man » Mon Mar 16, 2020 8:35 am

Right. I thought it was 256KB. All good. :)

Izen6
Posts: 53
Joined: Mon Jan 28, 2019 9:53 pm

Re: TL-ROM Splatterhouse

Post by Izen6 » Tue Mar 17, 2020 7:07 am

Thanks so much for everyone's help! So to clarify, lift pins 1, 2 and 24 and go pin 24 to pin 16 and pin 2 to hole 24?

FrankWDoom
Posts: 223
Joined: Mon Jan 23, 2012 11:27 pm

Re: TL-ROM Splatterhouse

Post by FrankWDoom » Tue Mar 17, 2020 9:49 am

Yea

Izen6
Posts: 53
Joined: Mon Jan 28, 2019 9:53 pm

Re: TL-ROM Splatterhouse

Post by Izen6 » Tue Mar 17, 2020 11:41 am

Thanks! I think I'm going to reprogram the chip first just to make sure it's good. Not looking forward to sticking wires from the lifted pins into the programmer, but it is what it is, haha.

Izen6
Posts: 53
Joined: Mon Jan 28, 2019 9:53 pm

Re: TL-ROM Splatterhouse

Post by Izen6 » Wed Mar 18, 2020 6:47 pm

So I finally got around to trying it, and I still get the same result. I noticed, before I put the chip back on that there's a scratch along a trace. I'm including a picture. It looks like it goes from pin 9 on the cart to pin 8 on the eprom. The scratch feels a little raised. Should I try a wire from pin 8 to the end of the cart?
Attachments
IMG_20200318_213246.jpg

Izen6
Posts: 53
Joined: Mon Jan 28, 2019 9:53 pm

Re: TL-ROM Splatterhouse

Post by Izen6 » Thu Mar 19, 2020 5:41 pm

So I tried soldering a wire from pin 8 to the end of the cart and same issue. I can't figure this one out. Chip is reprogrammed as well. I know for sure this works on a flash cart. Could it be the CHR?

Izen6
Posts: 53
Joined: Mon Jan 28, 2019 9:53 pm

Re: TL-ROM Splatterhouse

Post by Izen6 » Thu Mar 19, 2020 8:02 pm

Otherwise I'm wondering if the MMC3 patch plus the English patch on top of it is throwing it off? Motzilla does claim that his patch will work on TLROM, but I wonder if adding the other patch is messing something up. I didn't realize that the game is in English except for the title, so the English patch isn't really necessary.

FrankWDoom
Posts: 223
Joined: Mon Jan 23, 2012 11:27 pm

Re: TL-ROM Splatterhouse

Post by FrankWDoom » Thu Mar 19, 2020 10:53 pm

can you post a link to the english patch you're using

Izen6
Posts: 53
Joined: Mon Jan 28, 2019 9:53 pm

Re: TL-ROM Splatterhouse

Post by Izen6 » Fri Mar 20, 2020 5:04 am


Ice Man
Posts: 530
Joined: Fri Jul 04, 2014 2:34 pm

Re: TL-ROM Splatterhouse

Post by Ice Man » Fri Mar 20, 2020 5:15 am

I already did it on TLROM and it works perfectly fine.

What programmer are you using? Can you exclude a defect from the EPROM themselves?

Izen6
Posts: 53
Joined: Mon Jan 28, 2019 9:53 pm

Re: TL-ROM Splatterhouse

Post by Izen6 » Fri Mar 20, 2020 6:36 am

So strange. I'm using a Willem GQ4x4. Has worked perfectly fine for me before.

I believe the eproms I'm using are fine. I have extra eproms I could try, but I can't desolder my eproms on the board until Monday. My Hakko nozzle is clogged and waiting for new ones to arrive.

Can you please confirm your pinout with me?

Also, did you try getting to the second level? Use code 1055 and go through the first door and let me know what happens.

Ice Man
Posts: 530
Joined: Fri Jul 04, 2014 2:34 pm

Re: TL-ROM Splatterhouse

Post by Ice Man » Fri Mar 20, 2020 7:13 am

Already confirmed and told you multiple times as well as how to trouble shoot in your other thread...

And GQ-4X4 is trash. I only have bad experience with it, sadly.

Also, 2nd level works fine.

Post Reply