Repros work with TI 74LS257 but not Motorola?

A place that you can discuss reproduction of classic titles or "licensed-for-reproduction" homebrew for personal use.

Moderators: B00daW, Moderators

Forum rules
1. NO BLATANT PIRACY. This includes reproducing homebrew less than 10 years old, with the exception of free software.
2. No advertising your reproductions, with the exception of free software.
3. Be nice. See RFC 1855 if you aren't sure what this means.
Post Reply
Tormenter
Posts: 306
Joined: Sat Jun 03, 2006 9:17 pm

Repros work with TI 74LS257 but not Motorola?

Post by Tormenter » Sat Jan 02, 2021 9:43 pm

I have a few different brands of the 74LS257's, all work, TI etc, except Motorola. Some games, seems to work fine, but other games, it causes graphical and sound issues. Any idea why this would be? They are the same pinout etc. SN74LS256BN (TI, works fine), SN74LS257AN Motorola for example, causes issues in some games. I have verified this by swapping them out again on multiple occasions. Any idea why this would be happening, and/or a easy fix? Appreciate it.

lidnariq
Posts: 10260
Joined: Sun Apr 13, 2008 11:12 am
Location: Seattle

Re: Repros work with TI 74LS257 but not Motorola?

Post by lidnariq » Sun Jan 03, 2021 2:03 am

No idea if this is it, but that "A" vs "B" at the end denotes some change in specific properties (but not form fit or function). I can't find any useful documentation about the '257AN on line, however.

Any idea if the "some" games are FastROM vs SlowROM?

Also, the first two letters originally marked the silicon foundry that made the part, although that's not been particularly useful for quite a while now. SN = TI; MC = Motorola; CD = RCA.

krzysiobal
Posts: 829
Joined: Sun Jun 12, 2011 12:06 pm
Location: Poland

Re: Repros work with TI 74LS257 but not Motorola?

Post by krzysiobal » Sun Jan 03, 2021 2:13 am

Any schematic or photo of subjected cartridge to see what is this chip responsible for?
BW. From all cartridges I have analyzed so far, it appeared only twice:

1) Ai Senshi Nicol (FDS port)
sch.png
2) MGC-002 TXC's MMC1 replica
http://forums.nesdev.com/viewtopic.php?f=9&t=17067

Tormenter
Posts: 306
Joined: Sat Jun 03, 2006 9:17 pm

Re: Repros work with TI 74LS257 but not Motorola?

Post by Tormenter » Tue Jan 05, 2021 3:20 pm

I will get some photos. I use an adapter board that uses 2 of the chips. Most brands are fine, Motorola on the otherhand isnt, which is sad because i've got probably 500 of them here lol. I will have to try and remember which ones it didn't work with. Bahamut Lagoon for sure messed up on, while the TI and other brands work just fine. I am thinking some Super Metroid games didn't work with them either just off the top of my head.

lidnariq
Posts: 10260
Joined: Sun Apr 13, 2008 11:12 am
Location: Seattle

Re: Repros work with TI 74LS257 but not Motorola?

Post by lidnariq » Tue Jan 05, 2021 3:22 pm

Oh, also ... any chance the Motorola '257s are counterfeit? (e.g. not actually a LS part)

Tormenter
Posts: 306
Joined: Sat Jun 03, 2006 9:17 pm

Re: Repros work with TI 74LS257 but not Motorola?

Post by Tormenter » Tue Jan 05, 2021 9:48 pm

lidnariq wrote:
Tue Jan 05, 2021 3:22 pm
Oh, also ... any chance the Motorola '257s are counterfeit? (e.g. not actually a LS part)

I've gathered them over the year from several places. I think majority came from someone that I have never had an issue with. Some of the games load up but just have garbled graphics, or in parts of the game itll just cause it to glitch out etc.

Post Reply