Need help with Metroid Mother Repro

A place that you can discuss reproduction of classic titles or "licensed-for-reproduction" homebrew for personal use.

Moderators: B00daW, Moderators

Forum rules
1. NO BLATANT PIRACY. This includes reproducing homebrew less than 10 years old, with the exception of free software.
2. No advertising your reproductions, with the exception of free software.
3. Be nice. See RFC 1855 if you aren't sure what this means.
Post Reply
User avatar
Danexmurder
Posts: 10
Joined: Sun Dec 27, 2020 9:42 pm

Need help with Metroid Mother Repro

Post by Danexmurder » Wed Mar 10, 2021 12:52 am

I've hit a wall working on a repro for Metroid Mother. I'm trying to use the MetroidMother+99 hack. I've been wanting to play this on real hardware and thought that using a Muramasa TxSxRom Advanced board would get the job done. I set it up using 39SF040 chips for prog and chr rom. I included the AVRCIC so it would load on my frontloader. I'm using the AX5904 mapper. I get a black screen when I try to fire it up. I did get some Alliance AS6C6264 ram but am unsure if I should use it in the Wram spot. I tried it with and without and neither worked. I have my jumpers set to Rom on the front and back. MMC1 jumpers set everywhere else. Battery jumper set for the CR2032 battery. Any advice would be much appreciated.

User avatar
Danexmurder
Posts: 10
Joined: Sun Dec 27, 2020 9:42 pm

Re: Need help with Metroid Mother Repro

Post by Danexmurder » Wed Mar 10, 2021 1:38 am

I sorted this out myself but wanted to post for posterity. You DO need the Ram installed. The issue I was having was that I had the eprom jumper bridged as well as the two flash rom jumpers bridged. Once I unbridged the eprom jumper and reinstalled the ram it fired right up!

Post Reply