It is currently Mon Dec 11, 2017 2:12 pm

All times are UTC - 7 hours





Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Sat Aug 01, 2015 9:48 am 
Offline

Joined: Tue Jun 09, 2015 6:16 pm
Posts: 6
Location: Montréal
Graphically the game looks right, but I have some invisible platform and some hole in walls here and there (example:http://imgur.com/Jg5iUHK). I'm not sure what part of my emu is wrong on this. Could this be a cpu bug?


Top
 Profile  
 
PostPosted: Sun Aug 02, 2015 9:39 am 
Offline
User avatar

Joined: Mon Dec 29, 2014 1:46 pm
Posts: 750
Location: New York, NY
yanos wrote:
Could this be a cpu bug?


Does your emulator pass all the CPU test roms?


Top
 Profile  
 
PostPosted: Sun Aug 02, 2015 11:28 am 
Offline

Joined: Tue Jun 09, 2015 6:16 pm
Posts: 6
Location: Montréal
Yep. except some timing issue that I'm currently trying to fix.


Top
 Profile  
 
PostPosted: Sun Aug 02, 2015 2:41 pm 
Offline
Formerly Fx3
User avatar

Joined: Fri Nov 12, 2004 4:59 pm
Posts: 3076
Location: Brazil
Hmm... perhaps PPU mirroring is incorrect?


Top
 Profile  
 
PostPosted: Sun Aug 02, 2015 4:42 pm 
Offline

Joined: Tue Jun 09, 2015 6:16 pm
Posts: 6
Location: Montréal
I doubt it since if that's the case, EVERYTHING would be wrong. But it's only every so often here and there. It's quite puzzling :(


Top
 Profile  
 
PostPosted: Sun Aug 02, 2015 6:21 pm 
Offline
User avatar

Joined: Mon Dec 29, 2014 1:46 pm
Posts: 750
Location: New York, NY
yanos wrote:
I doubt it since if that's the case, EVERYTHING would be wrong. But it's only every so often here and there. It's quite puzzling


It looks like the status bar at the top is cutoff. Does the status bar look correct normally except when this happens?


Top
 Profile  
 
PostPosted: Sun Aug 02, 2015 6:57 pm 
Offline
User avatar

Joined: Fri Nov 19, 2004 7:35 pm
Posts: 3967
Double check the RAM implementation, that everything is mirrored correctly, and that addresses are correct.

_________________
Here come the fortune cookies! Here come the fortune cookies! They're wearing paper hats!


Top
 Profile  
 
PostPosted: Sun Aug 02, 2015 7:10 pm 
Offline
User avatar

Joined: Sat Jan 22, 2005 8:51 am
Posts: 427
Location: Chicago, IL
I'm unsure about the "platform", but there's something wrong with your sprite 0 hit detection code.

_________________
get nemulator
http://nemulator.com


Top
 Profile  
 
PostPosted: Mon Aug 03, 2015 6:26 am 
Offline

Joined: Tue Jun 09, 2015 6:16 pm
Posts: 6
Location: Montréal
Yeah, my sprite 0 hit detection is not is bogus, it's just not the priority right now. I'll check my ram implementation and mirroring code in the PPU.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group