nesdev.com
http://forums.nesdev.com/

APU pulse channel pitch sounds low
http://forums.nesdev.com/viewtopic.php?f=3&t=15444
Page 1 of 1

Author:  JSBryan [ Wed Jan 25, 2017 6:41 pm ]
Post subject:  APU pulse channel pitch sounds low

I am working on APU pulse channels. My music pitch sounds low. I didn't do down sampling or apply any enhancements. Is this normal or something is wrong with my period used in pulse waveform generator? If I use every other 40th samples, pitch sounds about right but it also sounds like there are gaps in between tones. Currently sweep and 11-bit timer can alter my period. Is there anything I am missing?

Author:  Disch [ Wed Jan 25, 2017 7:34 pm ]
Post subject:  Re: APU pulse channel pitch sounds low

You **MUST** do some form of down sampling. The NES outputs ~1790 KHz but you'll usually only want to output ~48 Khz (or 44KHz).

Outputting 1 sample every ~40 clocks is one form of downsampling (commonly referred to as "nearest neighbor"). It will work but will be very low quality. If the pitch sounds about right when doing that, then your pulse is probably fine -- you just need to properly downsample it.

Author:  Quietust [ Thu Jan 26, 2017 5:45 am ]
Post subject:  Re: APU pulse channel pitch sounds low

If you're downsampling to 44100Hz, your divider needs to be exactly 3125/77 for NTSC (1789772.72727... / 44100, around 40.5844) rather than an even 40, otherwise your pitches will be off.

Page 1 of 1 All times are UTC - 7 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/