nesdev.com
http://forums.nesdev.com/

Request analysis of my glitchy PPU implementation
http://forums.nesdev.com/viewtopic.php?f=3&t=16426
Page 1 of 1

Author:  clueless [ Tue Aug 29, 2017 6:32 pm ]
Post subject:  Request analysis of my glitchy PPU implementation

Hello. I am writing a NES emulator as a C++ library (with no dependencies) to be used as a component in a different project. I've written a Gtk "host" binary to test the emulator. I pass all of the "nestest.nes" CPU tests, plus dozens of my own CPU and PPU unit tests.

My PPU implementation is glitchy when scrolling The Legend of Zelda (in any direction) [1]. I've compared my PPU source code with 5 or 6 other emulators on github and I am unable to spot where I've screwed up. I was hoping that the nesdev wizards would be able to suggest things for me to re-examine based on the PPU behaviour and known behaviour of the game, as seen in the video.

My emulator plays non-scrolling games like Donkey Kong just fine, and scrolling in Final Fantasy 1 (single-screen mirroring) looks correct.

Thank you for your time.


[1] https://youtu.be/iDB1xCtqshw

Author:  lidnariq [ Tue Aug 29, 2017 6:42 pm ]
Post subject:  Re: Request analysis of my glitchy PPU implementation

That looks like a bug in your MMC1 implementation, not PPU.

Author:  tehcloud [ Fri Sep 01, 2017 9:11 am ]
Post subject:  Re: Request analysis of my glitchy PPU implementation

I agree that it is probably more MMC1 related, but it looks like you have sprite 0 hit issues too. That could be rooted in the MMC1 issues, however.

Page 1 of 1 All times are UTC - 7 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/