nesdev.com
http://forums.nesdev.com/

puNES Emulator
http://forums.nesdev.com/viewtopic.php?f=3&t=6928
Page 36 of 49

Author:  Andreytek [ Sun Sep 13, 2015 8:15 am ]
Post subject:  Re: puNES Emulator (ex Fnes)

puNES normal course emulyator.no me it lacks online play in Nestopia, in puNES no such function as a "kailleraclient" or " Master " Anti3D But okay , I did not play with other players via the Internet , but if I want to play through LAN ( , network cable , Ethernet call it what you want) , or if I want to play via Wi-Fi ( without the Internet ) with a neighbor on the 2 floors above (This is an example in Sega "Kega Fusion" is available ), then the emulator puNES not suitable , I I hope this message will not leave without attention and corrected in future versions :)

Incidentally enough to test on ancient operating systems , test on Windows 8 , Windows 8.1, Windows 10 32 -bit and 64-bit versions
And please do not throw the Russian language

Author:  FHorse [ Mon Sep 14, 2015 12:25 am ]
Post subject:  Version 0.97

Changelog:
0.97
- rewritten the audio stack to eliminate problems of lags and crackling.
- added in the audio settings new option "Buffer Size factor". To a lower value corresponds to a smaller size buffer (less lag but most possible crackles on slower computers). The larger the buffer, the greater the lag but less chance of crackles.
- added the "Stereo Panning" mode.
- eliminated the setting "Hide the mouse cursor". Now the mouse cursor is hidden automatically after two seconds of inactivity of the mouse. Appears again to mouse movement.
- updated the xBRZ to 1.4.
- added the "Fast Forward" to the shortcuts (keyboard and joystick).
- added an option to set the velocity of "Fast Forward".

Author:  Dark Frost [ Wed Sep 16, 2015 5:51 am ]
Post subject:  Re: puNES Emulator (ex Fnes)

First Thanks For This Emulator
Because İts Best :D
But This Emulator Not Have a backward rewind Functions
forward functions have but not have a rewind functions
Please Added New Revisions backward rewind Functions
Best Regards
Dark Frost

Author:  uVSthem [ Wed Sep 16, 2015 6:27 am ]
Post subject:  Re: puNES Emulator (ex Fnes)

Donating might motivate him to add these features.

Dark Frost wrote:
First Thanks For This Emulator
Because İts Best :D
But This Emulator Not Have a backward rewind Functions
forward functions have but not have a rewind functions
Please Added New Revisions backward rewind Functions
Best Regards
Dark Frost

Author:  Black Zero [ Wed Sep 16, 2015 11:46 pm ]
Post subject:  Re: Version 0.97

FHorse wrote:
Changelog:
0.97
- rewritten the audio stack to eliminate problems of lags and crackling.
- added in the audio settings new option "Buffer Size factor". To a lower value corresponds to a smaller size buffer (less lag but most possible crackles on slower computers). The larger the buffer, the greater the lag but less chance of crackles.
- added the "Stereo Panning" mode.
- eliminated the setting "Hide the mouse cursor". Now the mouse cursor is hidden automatically after two seconds of inactivity of the mouse. Appears again to mouse movement.
- updated the xBRZ to 1.4.
- added the "Fast Forward" to the shortcuts (keyboard and joystick).
- added an option to set the velocity of "Fast Forward".


Thanks for a new release!

However I have one thought though, in the about window it says 0.97 WIP
Is 0.97 a WIP release? Because that have to be the first time you take this approach because usually you send WIP builds via PM.

EDIT:

Everything good sound wise!

EDIT 2: Scratch that, see my new post...

Author:  Pie-jacker875 [ Sun Sep 20, 2015 7:10 pm ]
Post subject:  Re: puNES Emulator (ex Fnes)

Pretty enjoyable to use. I'd like more accurate FDS (and other) audio in the future. Zelda II has many obvious sound problems. Lagrange Point is off pitch when you use any sample rate other than 48000.

Author:  gumgum [ Tue Sep 22, 2015 12:12 pm ]
Post subject:  Re: puNES Emulator (ex Fnes)

Possible bug:
The puNES.cfg value for stereo panning is pannig (though the comment says to use panning). Does this typo have any bearing on the activation of the option? Attempting to correct the typo simply makes puNES reset to delay, even when the file is set to read-only (though then it's only in the application itself).

Author:  feos [ Sun Sep 27, 2015 12:48 pm ]
Post subject:  Re: puNES Emulator (ex Fnes)

Latest puNES now passes a few more tests.
http://tasvideos.org/EmulatorResources/ ... Tests.html

Author:  Zepper [ Sun Sep 27, 2015 5:44 pm ]
Post subject:  Re: puNES Emulator (ex Fnes)

feos wrote:
Latest puNES now passes a few more tests.
http://tasvideos.org/EmulatorResources/ ... Tests.html


Yeah... while my emulator still remains as 5.014 (latest public version is 5.142). Go figure. It's a nice table, but still outdated.

Author:  Black Zero [ Mon Sep 28, 2015 2:31 am ]
Post subject:  Re: puNES Emulator (ex Fnes)

This is a major edit so I deleted my previous comments

I can now say that the sound crackles/garbles on both Stereo Delay and Stereo Panning on v097
I have tested my games thoroughly and I can't get the sound not to crackle/garble, it happens all the time.

I have tested literally everything in the sound option section but it doesn't solve anything.

I thought Stereo Panning solved it but it started there as well, that's why I deleted my previous comments.

I'm on Windows 8.1 x64 and I use HDMI from the GPU to my TV to get sound. I use the SDL version of puNES.

The last working version that I used before v097 were v095 and the sound didn't crackle/garble there.

My system is:

i7 3770K
ASUS Raden R9 290
ASUS P8Z77 WS motherboard
Corsair XMS3 16Gb DDR3

I don't know what I should do???

EDIT 2:

I was able to find a link to v096 x64 SDL and the sound doesn't crackle/garble there.

That version doesn't have Stereo Delay or Stereo Panning just Mono and Stereo and no Buffer Size Factor either.

I don't know about the others here or if I'm the only one effected but v097 is totally broken for me when the sound crackles/garbles.

I'll have to use v096 for now.

Author:  Azeus [ Wed Sep 30, 2015 11:33 pm ]
Post subject:  Re: puNES Emulator (ex Fnes)

I'm experiencing sound crackling as well in the d3d version 0.97. After playing super mario 3 for about 4-5 min sound becomes badly distorted. I've tested on both of my machines which are way more than enough to run this emulator. Increasing the buffer size in audio settings doesn't help. My specs for both machines.

Desktop
MB: MAXIMUS VII FORMULA
Operating System: Windows 10 64-bit
Processor/CPU: i7 4790k
Video Card/GPU: Nvidia GTX 980
Memory/RAM: Corsair Vengeance lp 32gb GDDR3

Laptop
PC: MSI GT70 2PE Dominator Pro
Operating System: Windows 8.1 64-bit
Processor/CPU: 4th Gen Intel Core i7 4810MQ 2.8GHz-3.7GHz(Turbo)
Video Card/GPU: Nvidia GTX 880m 8gb GDDR5
Memory/RAM: 32gb GDDR3


Also can we get xinput support. The xbox one controller is bugged in Windows 10 with dinput and the controller cannot be configured with this emulator. Other games and emulators also have this issue with the xbox one controller when setting up dinput, this is a Windows 10 issue because all three of my xbox one controllers work fine with dinput games in Windows 8.1. That's why it would be much appreciated if xinput could be implemented as i prefer the xbox one controllers dpad over the 360's. The 360 controller works fine for dinput in Windows 10. Thanks i hope someone reads this.

Author:  rainwarrior [ Mon Oct 05, 2015 12:45 pm ]
Post subject:  Re: puNES Emulator (ex Fnes)

Power on state of RAM looks like:

?? ?? ?? FF FF FF FF FF F7 EF DF FF FF FF FF BF

then the rest is FF

Is there any particular reason you chose this very arbitrary pattern for power-on? (Copied from Nestopia?)

Edit: ?? because apparently the test ROM I was using zeroes the first 3 bytes

Author:  thefox [ Mon Oct 05, 2015 2:15 pm ]
Post subject:  Re: puNES Emulator (ex Fnes)

Probably from http://wiki.nesdev.com/w/index.php/CPU_power_up_state

Author:  Eugene.S [ Mon Oct 05, 2015 2:19 pm ]
Post subject:  Re: puNES Emulator (ex Fnes)

puNES now open-source:
https://github.com/punesemu
https://github.com/punesemu/puNES

Author:  Black Zero [ Mon Oct 05, 2015 10:32 pm ]
Post subject:  Re: puNES Emulator (ex Fnes)

Eugene.S wrote:


I was going to say "WHAAAAT???" because I was chocked and never thought this was going open source but then I thought "AWESOME"

This is gonna be so much easier to report problems.

Page 36 of 49 All times are UTC - 7 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/