nesdev.com
http://forums.nesdev.com/

NESICIDE
http://forums.nesdev.com/viewtopic.php?f=3&t=9275
Page 9 of 9

Author:  cpow [ Fri Oct 27, 2017 11:41 pm ]
Post subject:  Re: NESICIDE

v2.0.0 is out. This includes Windows, Linux, and OSX distributions. For the meanwhile they are temporarily stored on my server until I can get Travis/AppVeyor configured properly.

Download

As for features, not much new. Just getting back into it a bit. I have plans for a few things:

1. Better support for VICE C=64 integration. Loading/debugging via D64 disk images. Less 'buggy' remote monitor integration.
2. Solution-esque setup a la MSVS with multiple projects per solution.

Author:  Sumez [ Sat Oct 28, 2017 1:45 am ]
Post subject:  Re: NESICIDE

This comes up when you try to run the program:
Attachment:
printsupport.PNG
printsupport.PNG [ 8.88 KiB | Viewed 249 times ]

I tried stealing the DLL from my Dropbox installation, but I think it's a different version, it gives me another error regarding the entry point to a procedure.

Author:  cpow [ Sat Oct 28, 2017 7:38 am ]
Post subject:  Re: NESICIDE

Sumez wrote:
This comes up when you try to run the program:
Attachment:
printsupport.PNG

I tried stealing the DLL from my Dropbox installation, but I think it's a different version, it gives me another error regarding the entry point to a procedure.

Strange that windeployqt didn't pick that up. Hmmm.

Author:  cpow [ Sat Oct 28, 2017 8:23 am ]
Post subject:  Re: NESICIDE

Sumez wrote:
...

Try now. (Same link...)

Author:  Sumez [ Sat Oct 28, 2017 9:53 am ]
Post subject:  Re: NESICIDE

Seems to be working :) I'll let you know if I run into any other issues.

For the record, the emulator is as slow as it's always been (if not even slower?). I don't know what the issue is, but I'm getting the assumption that you prefer working with the Linux version yourself, so the problem could be specific to Windows :)

Author:  cpow [ Sat Oct 28, 2017 9:57 am ]
Post subject:  Re: NESICIDE

Sumez wrote:
Seems to be working :) I'll let you know if I run into any other issues.

For the record, the emulator is as slow as it's always been (if not even slower?). I don't know what the issue is, but I'm getting the assumption that you prefer working with the Linux version yourself, so the problem could be specific to Windows :)


What are your machine specs? I'll try on my native Win7 sometime today.

Author:  Sumez [ Sat Oct 28, 2017 10:18 am ]
Post subject:  Re: NESICIDE

Windows 8 64-bit on a laptop computer with a 1.90GHz Radeon R6.

Author:  cpow [ Sat Oct 28, 2017 12:55 pm ]
Post subject:  Re: NESICIDE

Sumez wrote:
Windows 8 64-bit on a laptop computer with a 1.90GHz Radeon R6.

Strange. It works fine with debugging enabled at update on pause on my Win7 laptop.
8GB RAM, dual i5 @2.6GHz
I know my emu isn't snappy especially when it's being debug-inspected more often than just "update on pause" but it should at least work without audio artifacts on a reasonable computer.
I wonder if it's a Windows 7/8 thing? Do you have access to any other Windows machines you can try it on? I'll check my work computer but even that is still Win7.

Author:  Sumez [ Sat Oct 28, 2017 2:58 pm ]
Post subject:  Re: NESICIDE

I've been using it on a Windows 10 computer with the same issue, but that's it. I'll see if I can find Windows 7 somewhere to see if it makes a difference.
As for audio artifacts, that's actually a big issue too :P It keeps making a clicking noise, but I always figured that's related.

Page 9 of 9 All times are UTC - 7 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/