Famicomstation questions.

You can talk about almost anything that you want to on this board.

Moderator: Moderators

Post Reply
Patnukem
Posts: 77
Joined: Thu Sep 10, 2020 11:16 pm

Famicomstation questions.

Post by Patnukem » Wed Sep 16, 2020 10:14 pm

Hi.

I recently got a Famicomstation and in the process of repairing it. I usually work on arcade machines but usually I can find a schematic to help me. Was there one in the original manual?

So far I fixed the power supply as it was outputting 14.8v instead of 5. The green light comes on but no video out that my lcd can pick up, on coax I get some white lines or black screen when it’s on depending on station and dip settings. I think the previous owner tried the old power supply with the high voltage so it’s likely this took some stuff out.

Any help appreciated, just kind of stuck at the moment on this one

User avatar
Memblers
Site Admin
Posts: 3899
Joined: Mon Sep 20, 2004 6:04 am
Location: Indianapolis
Contact:

Re: Famicomstation questions.

Post by Memblers » Thu Sep 17, 2020 2:05 am

The only manuals I've seen look like one they'd leave in the hotel room for the user, there probably is a service manual somewhere though, I don't know if it's been found. I'd imagine the circuit would be pretty similar to the NES schematic though, with the extra stuff bolted on.

https://problemkaputt.de/everynes.htm#famicombox
http://kevtris.org/mappers/famicombox/

Patnukem
Posts: 77
Joined: Thu Sep 10, 2020 11:16 pm

Re: Famicomstation questions.

Post by Patnukem » Thu Sep 17, 2020 6:26 am

I know the famicombox and famicom station came with two books one the yellow one found on a few sits and
The service manual, full size page white book. So far I’ve only found a few photos of them. I’ve reached out to a few people to see if they would share, no luck so far.

Patnukem
Posts: 77
Joined: Thu Sep 10, 2020 11:16 pm

Re: Famicomstation questions.

Post by Patnukem » Tue Sep 29, 2020 3:47 pm

Still looking for some help/direction fixing this guy. I fear some of the main board/games was hurt by the nearly 15v someone out into the 5v input. I was able to test the games and only some work, one was dead and the menu cart was not loading, though I don’t know if this is something that would normally work. Going to replace the transistors, diodes and other small semiconductor parts first and see where I’m at. Right now with a good cpu, ppu, power supply... I’m getting mostly black screen some artifacts and a constant hum.

Post Reply