It is currently Mon Dec 11, 2017 6:35 am

All times are UTC - 7 hours





Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: NOAC controller problem
PostPosted: Tue Jan 27, 2015 11:41 pm 
Offline

Joined: Thu Jul 04, 2013 11:32 am
Posts: 8
Hello,

I'm wiring up a Nes-on-a-chip system to be eventually worked into a portable console. I extracted the guts of the controller and wired tact switches to the traces where the buttons go. They all work except Up, Left, and Right. There doesn't seem to be an internal pullup on these buttons - their signal pins read only ~0.3 volts when the system is on, while the functional buttons all read closer to 4. I tried an external pullup to get the signal high and that didn't work. The only times these buttons have worked (since I ripped the controller IC out) have been when I accidentally soldered directly to the trace while the system was on. Very weird. I think something's wrong inside the IC. Has anyone else run into a problem like this?

My other option is to get some 4021s shift registers and build my own controller board. Anyone done this?

Graham


Top
 Profile  
 
PostPosted: Wed Jan 28, 2015 4:02 pm 
Offline

Joined: Thu Jul 04, 2013 11:32 am
Posts: 8
I tried another controller and that worked fine so I trashed the first one.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: bazza and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group