nesdev.com
http://forums.nesdev.com/

NES GRAY SCREEN AND I TRIED EVERYTHING
http://forums.nesdev.com/viewtopic.php?f=9&t=16212
Page 1 of 1

Author:  sicktoms [ Sat Jul 15, 2017 12:29 am ]
Post subject:  NES GRAY SCREEN AND I TRIED EVERYTHING

Hi guys i've had this nes for over a couple of years right now but i have never been able to get it working.
I've tried everything right now to fix the solid gray screen it gives me every time.
I've tried re-bending the pins, replacing the 72 pin connector entirely, polishing the edge connector fingers on the mobo. I've even tried feeding it DC as GameTechUS suggested on his channel. It has been region unlocked by cutting the cic leg.
The motherboard looks in very good condition and i don't have a clue on what to do.
Last thing is that sometimes on the gray screen appear a couple of black characters in a random position on the screen but it happens very rarely and i couldn't figure out why they do.
Thanks in advance and greetings from Italy guys!
Image
Image
Image

Author:  Jeroen [ Sat Jul 15, 2017 9:27 am ]
Post subject:  Re: NES GRAY SCREEN AND I TRIED EVERYTHING

Gray screen with no audio is most likely your cpu not running for some reason. There's several reasons why this could be. The most obvious is of course a bad connector, but it seems you have tried a reasonable amount of things to fix that.
Sadly it's hard to say why your cpu isn't running, it could just be a corroded trace. It could be bad RAM. You could try replacing the caps (although I think you'd probably get SOME output if it was the caps).

Also your images aren't showing up.

Do you have any test equipment like a multimeter and/or an oscilloscope?

Author:  sicktoms [ Sat Jul 15, 2017 10:30 am ]
Post subject:  Re: NES GRAY SCREEN AND I TRIED EVERYTHING

sorry the images aren't showing up i'll link them here:
https://www.dropbox.com/s/rg2l95mhbeacm ... 0.jpg?dl=0
https://www.dropbox.com/s/ypvs37dkn5dlc ... 1.jpg?dl=0
https://www.dropbox.com/s/1hadw4j34u85h ... 2.jpg?dl=0

Yes i do have a multimeter i checked voltage on all the chips and rams and they all get 5 volts.

the next part is a bit off-topic even if it is a nes
i picked up today another one for parts it has another strange problem basically it works kind of fine but the video as a strange interference but if i keep connected my component audio and i touch the component video connector to pin 21 of the ppu the interference goes out but obviously the picture is much more darker because i'm bypassing the amplifier. is this a good candidate for bad main cap or all caps?
UPDATE: The second nes does it only on composite on rf it works fine again what could be the culprit ?

Author:  Jeroen [ Sat Jul 15, 2017 11:55 am ]
Post subject:  Re: NES GRAY SCREEN AND I TRIED EVERYTHING

If you had a scope or a logic probe you could see if the adress/data lines are at least doing something (and wether the ppu is receiving them, the ram is receiving them etc). Since you don't seem to have one, you could try desoldering the cpu/ppu/ram and swapping them to a known working unit.

Don't forget to double check dumb problems, is your game clean? Does it work on another nes?

The interference on the second NES sounds like it might be solved by recapping it. Hard to say for sure without seeing the interference.

edit: you could try measuring the RESET line on the cpu. During operation it should be HIGH. (5v+) If its stuck low the CIC becomes a suspect.

Author:  sicktoms [ Sat Jul 15, 2017 3:49 pm ]
Post subject:  Re: NES GRAY SCREEN AND I TRIED EVERYTHING

thanks a lot for all your suggestions unfortunately from tomorrow i'll be out of home till thursday so i cannot keep on doing the repairs i'll let you know as soon as i get my hands on them!

Author:  sicktoms [ Sat Jul 22, 2017 6:36 am ]
Post subject:  Re: NES GRAY SCREEN AND I TRIED EVERYTHING

UPDATE

the nes with bad video is on hold until i get the cap kit which i've ordered

the other nes, the one with the grey screen, i've measured the rst line and it is high 5v it goes low only when i press the reset button which is normal.

i'm really running out of ideas

Author:  mikejmoffitt [ Tue Jul 25, 2017 7:46 pm ]
Post subject:  Re: NES GRAY SCREEN AND I TRIED EVERYTHING

Touch audio to the high address lines of the CPU and listen for sounds, it's a poor man's oscillophone.

Author:  Fisher [ Wed Jul 26, 2017 8:14 am ]
Post subject:  Re: NES GRAY SCREEN AND I TRIED EVERYTHING

I once had a NES clone that had the same problem.
It was the CPU that was dead.
I replaced it and everything went fine.
You could try to put sockets on the board where there's some suspicious IC, this make simple substitution tests a lot easier.
Also, sometimes bad ICs generate a lot of heat, this can be a clue of what to try next.

Page 1 of 1 All times are UTC - 7 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/