Solid grey screen/graphical issue but not on all games?

Discuss hardware-related topics, such as development cartridges, CopyNES, PowerPak, EPROMs, or whatever.

Moderators: B00daW, Moderators

Post Reply
Posts: 1
Joined: Fri Dec 11, 2020 5:15 pm

Solid grey screen/graphical issue but not on all games?

Post by Snickersvickers » Sat Dec 12, 2020 2:47 am

Hi all,

So i recently got hold of a NTSC NES (live in UK) to replace my PAL (60hz fanboy). I tested it via composite and all seemed to work ok. I went on to install the NESRGB Tim Worthington mod, remove pin 4 on lockout chip and all good there. Picture is fantastic like on my PAL but in 60hz full speed and all that jazz which is what i wanted.

However, here's the issue.... Using my N8 everdrive i played some games only to find some odd things happening:

Super Mario Bros: Plays fine, but get to very near the end of the 1st level and it freezes??? Same spot every time. Tried different rom versions and even the real cart...Still the exact same spot

Kirby: Strange graphical glitches, everdrive or real cart

Castlevania 1: Grey screen (everdrive)

Contra: Grey Screen (everdrive)

Journey to Silius: Works fine, played 20mins or so with no problems

Haven't played any others as i stopped since my favorites aren't working i wanted to fix it.

So first things first the 72 pin connector, do the old boil trick.... didn't help. Buy a new 72 pin connector... still the same. Reflow the pads and tin the vias on the PCB board... still the same issue. (maybe bridge pads to vias?). Of course, i checked for continuity on all pins which all sound out though i did read or see somewhere that the traces could have hairline fractures that can cause issues?

So next step is to work out if I have perhaps a bad cpu,ppu or ram? I have a couple of Japanese Famicoms which i could take out chips to test. Are these compatible to use?

Either way, i just wanted to reach out to anyone who could shed some light on where to look next or has had any experience with an issue like this and hopefully an answer in to fixing this thing!

Post Reply