Rolling video w/a particular game pak (The Immortal; TLROM).

Discuss hardware-related topics, such as development cartridges, CopyNES, PowerPak, EPROMs, or whatever.

Moderators: B00daW, Moderators

CZroe
Posts: 32
Joined: Mon Apr 04, 2016 7:59 am

Rolling video w/a particular game pak (The Immortal; TLROM).

Post by CZroe » Mon Apr 04, 2016 8:33 am

I have a copy of The Immortal that was sold as-is/broken, but I thought it was curious enough to make a post about because I have never seen anything else like it.

I demonstrate the issue with two different TVs with very different results in this video:
https://youtu.be/3fhyX3HdVcg

First, it's a TLROM board and I verified other TLROM games working on the same consoles. I verified that it was an NTSC ROM. It's been tested on multiple consoles:
unmodified front loader
unmodified top loader
frontloader with CIC disabled
frontloader with Blinking Light Win v2 installed and ~15 unused pins removed
whatever console the previous owner was using

I've tested it with multiple CRTs and LCDs. I get a very different effect on LCDs (less stable image) but the image rolls on both.

I've got a feeling that replacing the capacitor might fix this, but I'm still curious to know what could be causing it. I've read that a lot of MMC3 games use a scanline counter to have static HUD with a scrolling screen and I'd guess that miscounting could cause a rolling issue but I don't see a static HUD in this game.

Ignore my brother talking about CGA graphic conversion. :P
Last edited by CZroe on Mon Apr 04, 2016 10:57 am, edited 1 time in total.

User avatar
thefox
Posts: 3141
Joined: Mon Jan 03, 2005 10:36 am
Location: Tampere, Finland
Contact:

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by thefox » Mon Apr 04, 2016 9:45 am

It is caused by the game using a known invalid color value ($0D): viewtopic.php?f=2&t=13504&p=159590#p159590

Nothing you can really do to fix it apart from replacing the PRG-ROM with a patched ROM that uses a proper black like $0F instead of $0D. (Or get a TV that doesn't have a problem with $0D.)
Download STREEMERZ for NES from fauxgame.com! — Some other stuff I've done: fo.aspekt.fi

CZroe
Posts: 32
Joined: Mon Apr 04, 2016 7:59 am

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by CZroe » Mon Apr 04, 2016 9:56 am

thefox wrote:It is caused by the game using a known invalid color value ($0D): viewtopic.php?f=2&t=13504&p=159590#p159590

Nothing you can really do to fix it apart from replacing the PRG-ROM with a patched ROM that uses a proper black like $0F instead of $0D. (Or get a TV that doesn't have a problem with $0D.)
Interesting. I'm reading it but right off the bat I have to wonder if that's really it:
It didn't work with at least four different CRTs with no image processor
and the same consoles/TVs worked great with Camerica games (Micro Machines, Quattro Sports, Game Genie, and one other Quattro game). This problem with The Immortal seems to affect all TVs and consoles.

I'll try to test it with the oldest TV I can find or with my NES that only outputs B&W to see what happens. Thanks!

Also, I've googled plenty and couldn't find reports of this with this particular game. If that is the same issue then it's the first report I've come across despite searching. Thanks again!

User avatar
thefox
Posts: 3141
Joined: Mon Jan 03, 2005 10:36 am
Location: Tampere, Finland
Contact:

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by thefox » Mon Apr 04, 2016 11:49 am

If you have a flash cart such as PowerPak or EverDrive you can try whether you get the same problem with it.
Download STREEMERZ for NES from fauxgame.com! — Some other stuff I've done: fo.aspekt.fi

CZroe
Posts: 32
Joined: Mon Apr 04, 2016 7:59 am

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by CZroe » Mon Apr 04, 2016 12:50 pm

thefox wrote:If you have a flash cart such as PowerPak or EverDrive you can try whether you get the same problem with it.
Unfortunately, I do not. :( Thanks, though.

User avatar
rainwarrior
Posts: 7677
Joined: Sun Jan 22, 2012 12:03 pm
Location: Canada
Contact:

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by rainwarrior » Mon Apr 04, 2016 2:21 pm

If you have a game genie, you can use it to patch out some of the offending code that produces the $0D colour. A while back I worked out a couple of codes that helped with The Immortal:

1. GEOATSKV (title)
1. GPVEASKN (walking around)
3. GPOEGSKN (battle)
4. GOUEYNKN (paused)

Edit: sorry, these don't actually do what I thought. I'm realizing now that these were for removing the "emphasis" The Immortal uses to darken the screen further. They don't actually remove the $0D colour, I don't think.

These might help, though. Perhaps the problem with the Immortal and not other games is that it additionally darkens it with the emphasis bits? These do disable that, I think.

CZroe
Posts: 32
Joined: Mon Apr 04, 2016 7:59 am

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by CZroe » Mon Apr 04, 2016 6:56 pm

Well, you guys were right: it was definitely the TV not liking this particular game. I tried yet another TV and it looked great. The B&W NES I have changed nothing. Thanks guys!
rainwarrior wrote:If you have a game genie, you can use it to patch out some of the offending code that produces the $0D colour. A while back I worked out a couple of codes that helped with The Immortal:

1. GEOATSKV (title)
1. GPVEASKN (walking around)
3. GPOEGSKN (battle)
4. GOUEYNKN (paused)

Edit: sorry, these don't actually do what I thought. I'm realizing now that these were for removing the "emphasis" The Immortal uses to darken the screen further. They don't actually remove the $0D colour, I don't think.

These might help, though. Perhaps the problem with the Immortal and not other games is that it additionally darkens it with the emphasis bits? These do disable that, I think.
I'm excited to try them tonight. Thanks a ton!

CZroe
Posts: 32
Joined: Mon Apr 04, 2016 7:59 am

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by CZroe » Mon Apr 04, 2016 9:23 pm

rainwarrior wrote:If you have a game genie, you can use it to patch out some of the offending code that produces the $0D colour. A while back I worked out a couple of codes that helped with The Immortal:

1. GEOATSKV (title)
1. GPVEASKN (walking around)
3. GPOEGSKN (battle)
4. GOUEYNKN (paused)

Edit: sorry, these don't actually do what I thought. I'm realizing now that these were for removing the "emphasis" The Immortal uses to darken the screen further. They don't actually remove the $0D colour, I don't think.

These might help, though. Perhaps the problem with the Immortal and not other games is that it additionally darkens it with the emphasis bits? These do disable that, I think.
Awesome! They definitely work. Thanks! Only issue is that the Game Genie only allows three at once, but I guess we can do without the title or pause screens. ;)

Well, I guess there was one other little issue:
The codes labeled "walking around" and "paused" are reversed and the numbering is a little wonky...

...but seriously: AWESOME! Thanks again. :D

Edit: well, I did a bit of testing and these are the effects I've noticed so far:
1. GEOATSKV (pause; title w/out sprite; dialog)
2. GPVEASKN (sprite; encounter screen)
3. GPOEGSKN (battle)
4. GOUEYNKN (walking around)

The "w/out sprite" thing is because the screen would scramble as soon as the wizard walked on the screen. If I enter the sprite code instead the screen will stabilize as soon as the wizard walks on screen. "Encounter screen" is just before the battle screen.
Last edited by CZroe on Tue Apr 05, 2016 5:54 am, edited 1 time in total.

User avatar
thefox
Posts: 3141
Joined: Mon Jan 03, 2005 10:36 am
Location: Tampere, Finland
Contact:

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by thefox » Mon Apr 04, 2016 10:53 pm

Here are the patches for actually patching out the $0D color and not the emphasis bits. Had these figured out some time ago, just wasn't sure which ones affected which parts of the game.

Code: Select all

0001F7B9: 0D 0F <- battle
0001F7D9: 0D 0F <- title screen
0001F7F9: 0D 0F <- walking around
0001F7FE: 0D 0F <- sprite color (used in e.g. wizards robe in some places)
Game Genie codes:

Code: Select all

YEXNPNIE <- battle
YEKNPNIE <- title screen
YEVNPNIE <- walking around
YEVNTNIE <- sprite color
Offsets $1F7EA..1F7EC also have $0D, but I'm not sure if that colorset is actually used anywhere (couldn't trigger it from the intro).
Download STREEMERZ for NES from fauxgame.com! — Some other stuff I've done: fo.aspekt.fi

CZroe
Posts: 32
Joined: Mon Apr 04, 2016 7:59 am

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by CZroe » Tue Apr 05, 2016 8:03 am

Here are the effects of a few of your memory patches:
https://youtu.be/pZsFJjGAdj4

Either removing the emphasis or changing the value for black seems to fix it on this particular TV. Thanks, guys! Now I just need a Game Genie that supports more simultaneous cheats. :)

User avatar
rainwarrior
Posts: 7677
Joined: Sun Jan 22, 2012 12:03 pm
Location: Canada
Contact:

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by rainwarrior » Tue Apr 05, 2016 11:40 am

You can stack two game genies for that. ;)

CZroe
Posts: 32
Joined: Mon Apr 04, 2016 7:59 am

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by CZroe » Tue Apr 05, 2016 6:53 pm

rainwarrior wrote:You can stack two game genies for that. ;)
Tried it and it works great! Now I have a reason to keep these two Game Genies around. I should probably mod the junky-lookin' one to fit a top-loader. I'm going to check and see if anyone ever made a replacement 3D-printed shell for that.

Great Hierophant
Posts: 745
Joined: Tue Nov 23, 2004 9:35 pm

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by Great Hierophant » Wed Apr 06, 2016 6:26 am

I would guess that The Immortal now works in the Sharp Famicom TV, Sharp Famicom Titler as well as games that break TVs synchronization with palette value 0D with these patches.

CZroe
Posts: 32
Joined: Mon Apr 04, 2016 7:59 am

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by CZroe » Fri Apr 08, 2016 4:48 am

Great Hierophant wrote:I would guess that The Immortal now works in the Sharp Famicom TV, Sharp Famicom Titler as well as games that break TVs synchronization with palette value 0D with these patches.
Just Googled and can't find a report of The Immortal not working with a Sharp Famicom TV. Was that reported to be the case?

tepples
Posts: 21752
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Rolling video w/a particular game pak (The Immortal; TLR

Post by tepples » Fri Apr 08, 2016 5:11 am

NesCartDB has no report of The Immortal having been released outside North America. (If there were such a report, there would be a flag of Japan in "More Profiles".) The 72-pin Sharp NES TV used the composite PPU, not the RGB PPU.

Post Reply