Multicarts not working on Famicom Classic

Discuss hardware-related topics, such as development cartridges, CopyNES, PowerPak, EPROMs, or whatever.

Moderators: B00daW, Moderators

Post Reply
User avatar
MaarioS
Posts: 146
Joined: Wed Jul 22, 2009 8:53 am

Multicarts not working on Famicom Classic

Post by MaarioS » Tue Feb 06, 2018 5:15 pm

Hi there, I struggle with a problem I can't solve by now. I have a Famicom Classic console (the first version, not classic mini) that functions rather strange- all normal carts work just fine and the games work just as normal and you can play through them but all multicarts I have simply refuse to work. They freeze right on the selection menu or while the game starts. There is no exception, ALL multicarts I have just don't work at all

What I've done is change 74LS139 into a new one, replaced the voltage regulator for a new one and added a small capacitor to the PCB from another Famicom (originally I noticed some empty slot for a small cap so I added it) but there is absolutely no change whatsoever, the console behaves the same. I think there is some problem with M2 pin or clock in the console but can anyone guess what may be faulty here the most likely?? Maybe some small component should be replaced or changed or something??
http://nesdev.com/Ntd_8bit.jpg

Please for help and suggestions, many thanks in advance!!

tepples
Posts: 21748
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Multicarts not working on Famicom Classic

Post by tepples » Tue Feb 06, 2018 5:38 pm

The Control Deck is model HVC-001, correct?

Do you have an adapter to try 72-pin cartridges like Super Mario Bros./Duck Hunt and Donkey Kong Classics?

User avatar
MaarioS
Posts: 146
Joined: Wed Jul 22, 2009 8:53 am

Re: Multicarts not working on Famicom Classic

Post by MaarioS » Tue Feb 06, 2018 5:43 pm

Yes the model is HVC-001. I don't even have Mario Duck Hunt carts or any NES carts lol

krzysiobal
Posts: 589
Joined: Sun Jun 12, 2011 12:06 pm
Location: Poland

Re: Multicarts not working on Famicom Classic

Post by krzysiobal » Tue Feb 06, 2018 6:17 pm

Try bigger capacitor for the one that holds console in reset after powerup.

User avatar
MaarioS
Posts: 146
Joined: Wed Jul 22, 2009 8:53 am

Re: Multicarts not working on Famicom Classic

Post by MaarioS » Tue Feb 06, 2018 6:43 pm

OK bigger but what value?? The original cap is 0.47uF if that's the correct cap I'm looking for but I don't think it's the issue here. I just soldered 2x 0.47uF = 0.94uF in place and still no luck, the same things happen...

Ice Man
Posts: 368
Joined: Fri Jul 04, 2014 2:34 pm

Re: Multicarts not working on Famicom Classic

Post by Ice Man » Wed Feb 07, 2018 3:39 am

Multi carts sometimes rely on the CIC (RESET Signal) from what I noticed. If using a NES anyway. But that's not the case.

Also check if CHR ROM /OE is connected to cartridge connector pin 17. If it isn't lift it from the board and connect it there.

Got any pictures of the carts PCB (front/back)?

User avatar
MaarioS
Posts: 146
Joined: Wed Jul 22, 2009 8:53 am

Re: Multicarts not working on Famicom Classic

Post by MaarioS » Wed Feb 07, 2018 4:25 am

WTF its not the case here... Those multicarts are made in 1990s and they are 100% fine

User avatar
MaarioS
Posts: 146
Joined: Wed Jul 22, 2009 8:53 am

Re: Multicarts not working on Famicom Classic

Post by MaarioS » Wed Feb 07, 2018 10:31 am

On the side note, I heard that there are some Famicom motherboard revisions with minor changes, my Famicom is HVC-CPU-05 that causes problems with multicarts. Anyone have any idea how to fix it if possible??

tepples
Posts: 21748
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Multicarts not working on Famicom Classic

Post by tepples » Wed Feb 07, 2018 10:33 am

Someone else had a problem with multicarts on HVC-CPU-05 revision. The earliest boards, especially from the square button era, may have different electrical characteristics that cause M2-interruption reset detectors to perform less reliably.

User avatar
MaarioS
Posts: 146
Joined: Wed Jul 22, 2009 8:53 am

Re: Multicarts not working on Famicom Classic

Post by MaarioS » Wed Feb 07, 2018 10:59 am

tepples wrote:Someone else had a problem with multicarts on HVC-CPU-05 revision. The earliest boards, especially from the square button era, may have different electrical characteristics that cause M2-interruption reset detectors to perform less reliably.
Wow this looks like my problem actually. Do you have any solution for this?? I couldn't spot any definitive answer in those topics

User avatar
MaarioS
Posts: 146
Joined: Wed Jul 22, 2009 8:53 am

Re: Multicarts not working on Famicom Classic

Post by MaarioS » Thu Feb 08, 2018 11:30 am

OK, it looks like I've found solution to my own problem (probably)- it looks like the CPU is probably defective. I have no idea whether these older CPUs are worse or my unit was just broken. I did a test where I swapped CPUs between this faulty Famicom Classic and working Famicom AV. Once I tested Famicom AV with the iffy CPU, multicarts didn't work and normal games worked even worse, overall the console behaves strangely but when I tested Famicom Classic with Famicom AV CPU, the console worked perfectly fine, even with all multicarts. So to everyone that has a Famicom Classic with the motherboard HVC-CPU-05 I suggest you should test if your board can play multicarts or flashcarts like Everdrive. Looks like the worst possible scenario unfortunately but at least I've found the issue, the only thing I can do here is swap the processor from another donor I think

lidnariq
Posts: 8769
Joined: Sun Apr 13, 2008 11:12 am
Location: Seattle

Re: Multicarts not working on Famicom Classic

Post by lidnariq » Thu Feb 08, 2018 12:31 pm

The 2A03 is significantly different from the later 2A03E and 2A03G CPUs in ways that are known to be incompatible. For example, Vs. System mainboards won't work at all if given a newer CPU.

I wouldn't assume that your 2A03letterless is defective at all.

User avatar
MaarioS
Posts: 146
Joined: Wed Jul 22, 2009 8:53 am

Re: Multicarts not working on Famicom Classic

Post by MaarioS » Thu Feb 08, 2018 1:02 pm

The part number is RP2A03, so yes it is letterless. Does it mean that the CPU is probably "100% working" but it is incompatible?? If I can't play any multicarts then the CPU might as well just be defective for me...

lidnariq
Posts: 8769
Joined: Sun Apr 13, 2008 11:12 am
Location: Seattle

Re: Multicarts not working on Famicom Classic

Post by lidnariq » Thu Feb 08, 2018 1:26 pm

Yeah, I'd say it's exactly that. "100% working but incompatible"

I suspect someone else would happily trade a functioning later-revision famicom for your older less-compatible famicom.

User avatar
MaarioS
Posts: 146
Joined: Wed Jul 22, 2009 8:53 am

Re: Multicarts not working on Famicom Classic

Post by MaarioS » Thu Feb 08, 2018 1:30 pm

If you or anyone else is interested in buying or trading this unit then you are free to go. The console was meant to be given away and it has been AV modded, as well as reduced jailbars ;)

Post Reply