It is currently Sat Oct 21, 2017 9:55 pm

All times are UTC - 7 hours





Post new topic Reply to topic  [ 50 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject:
PostPosted: Wed Feb 01, 2012 7:56 pm 
Offline
NESICIDE developer
User avatar

Joined: Mon Oct 13, 2008 7:55 pm
Posts: 1026
Location: Minneapolis, MN
lidnariq wrote:
cpow wrote:
Might I also ask...how is the emulator, performance-wise [since you say your computer sucks? On my Win7 lappy with Ubuntu in a VBox I get crap performance in Ubuntu, but great performance in Win7. I'm going to go native Ubuntu at some point...just not ready yet.
Pretty atrocious. Athlon tbird/1333, Matrox G450, nesicide-emulator is somewhere around ⅓ real time. Worse when GL is enabled, maybe a factor of 2, but without an FPS meter anyway it's hard to tell how much. Without GL it's worse by an additional factor of four when inside the IDE? But really, this is all guesswork from the listening to the gaps between audio packets.

Thanks. I expected I'd have to be doing some optimizing...1333MHz single core seems like a respectable lower limit. But of course my headache is figuring out how to optimize but still present an as-close-to-accurate representation of the internal state of the CPU/APU/PPU as possible. I know I canget there with a catch-up approach, that catches up on any breakpoints...just need to find the time to rework my emu core library!


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 01, 2012 8:23 pm 
Offline
Formerly ~J-@D!~
User avatar

Joined: Sun Mar 12, 2006 12:36 am
Posts: 445
Location: Rive nord de Montréal
cpow wrote:
~J-@D!~ wrote:
Here running x86_64 Ubuntu 11.10. apt-get -f install tries to remove nesicide. Cause: dependency to libqtwebkit4:386. Note that I already have libqtwebkit4.


Yeah something's not making Software Center happy...I think because libqtwebkit4 is 'untrusted'.

If I do:

sudo dpkg -i nesicide_1.014-1_i386.deb

that eventually concludes that I have an unmet dependency on libqtwebkit4. Then, doing:

sudo apt-get -f install

fixes it and finishes the install.

Could you do me a favor and try the sudo dpkg I did and post that [PM if you want]?

I already did this that way. I redid it (I removed nesicide before obviously) :
Code:
jarhmander@jarhmander-tux-PC:~/Downloads$ sudo dpkg -i nesicide_1.014-1_i386.deb
[sudo] password for jarhmander:
Selecting previously deselected package nesicide:i386.
(Reading database ... 338342 files and directories currently installed.)
Unpacking nesicide:i386 (from nesicide_1.014-1_i386.deb) ...
dpkg: dependency problems prevent configuration of nesicide:i386:
 nesicide:i386 depends on libqtwebkit4.
dpkg: error processing nesicide:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for software-center ...
Updating software catalog...this may take a moment.
Software catalog update was successful.
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Errors were encountered while processing:
 nesicide:i386


Code:
jarhmander@jarhmander-tux-PC:~/Downloads$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  nesicide:i386
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 2,791 kB disk space will be freed.
Do you want to continue [Y/n]?


I do have libqtwebkit4 installed, as I stated in my last post. Maybe this debian package is screwed up with 64 bit OS? Ideally, this should be tested on another 64 bit Ubuntu machine --- native, not through a VM, like me.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 01, 2012 8:48 pm 
Offline
Formerly 65024U

Joined: Sat Mar 27, 2010 12:57 pm
Posts: 2257
Any advice on installing this on a x64 Ubuntu 11.04 Classic? Wouldn't install the 386 package.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 02, 2012 8:09 am 
Offline
NESICIDE developer
User avatar

Joined: Mon Oct 13, 2008 7:55 pm
Posts: 1026
Location: Minneapolis, MN
3gengames wrote:
Any advice on installing this on a x64 Ubuntu 11.04 Classic? Wouldn't install the 386 package.


Can you elaborate on "wouldn't install"?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 02, 2012 8:17 am 
Offline
Formerly 65024U

Joined: Sat Mar 27, 2010 12:57 pm
Posts: 2257
I opened the .deb package and it wouldn't let me install on my x64 Ubuntu 11.04 computer.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 02, 2012 10:37 am 
Offline
NESICIDE developer
User avatar

Joined: Mon Oct 13, 2008 7:55 pm
Posts: 1026
Location: Minneapolis, MN
3gengames wrote:
I opened the .deb package and it wouldn't let me install on my x64 Ubuntu 11.04 computer.


Ok here's what I did...

1. Created a Ubuntu 11.04 VM from the ISO for X86 in VirtualBox on my Win7 64-bit laptop.
...
2. Performed the following commands:
a. wget https://sites.google.com/site/nesicidep ... 1_i386.deb
b. wget https://sites.google.com/site/nesicidep ... 1_i386.deb
c. wget https://sites.google.com/site/nesicidep ... 1_i386.deb
d. sudo dpkg -i libnesicide-emulator_1.004-1_i386.deb
e. sudo dpkg -i nesicide-emulator_1.004-1_i386.deb
f. sudo apt-get -f install
g. sudo dpkg -i nesicide_1.004-1_i386.deb
h. sudo apt-get -f install

The two sudo apt-get steps were required to resolve the dependencies on Qt libraries.

After that both apps are functional. I guess I need to go native Ubuntu 11.04 on this machine and try it there.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 18, 2012 2:11 pm 
Offline
Formerly 65024U

Joined: Sat Mar 27, 2010 12:57 pm
Posts: 2257
Finally got around to booting up ubuntu and this is what I get on the depackage commands:

Code:
aaron@Aarons-Laptop:~$ sudo dpkg -i libnesicide-emulator_1.004-1_i386.deb
dpkg: error processing libnesicide-emulator_1.004-1_i386.deb (--install):
 package architecture (i386) does not match system (amd64)
Errors were encountered while processing:
 libnesicide-emulator_1.004-1_i386.deb


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 19, 2012 7:02 am 
Offline

Joined: Sun Sep 19, 2004 11:12 pm
Posts: 19115
Location: NE Indiana, USA (NTSC)
Did you try using 32-bit Ubuntu instead of 64-bit Ubuntu?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 19, 2012 9:28 am 
Offline
Formerly 65024U

Joined: Sat Mar 27, 2010 12:57 pm
Posts: 2257
I'm assuming that'd work, but I don't have a 32-bit PC with ubuntu at the moment.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 19, 2012 6:30 pm 
Offline
User avatar

Joined: Thu Dec 03, 2009 8:20 am
Posts: 72
Hey guys, I'm the "Linux Nerd" in the credits for Nesicide. I didn't realize there was an actual interest in Nesicide with 64-bit platforms. It should run just fine, deps considered as we do have working version with 64-bit OSX (at least at one point)... If you want to express some interest, you should hop onto #nesicide on irc.freenode.net as I literally never check these forums :) I can most likely get some packages together by the end of this weekend with someone helping me test -- assuming everyone is talking about x86-64 platforms.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 20, 2012 9:57 am 
Offline
Formerly 65024U

Joined: Sat Mar 27, 2010 12:57 pm
Posts: 2257
I give up on other IRC's, so I'll just say it here. I run AMD x64.


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 03, 2012 9:18 am 
Offline
Formerly 65024U

Joined: Sat Mar 27, 2010 12:57 pm
Posts: 2257
Any news on this yet for a 64-bit deb? I know it should work, but what I can't install at all, I can't even run 32-bit.


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 03, 2012 10:28 am 
Offline
NESICIDE developer
User avatar

Joined: Mon Oct 13, 2008 7:55 pm
Posts: 1026
Location: Minneapolis, MN
3gengames wrote:
Any news on this yet for a 64-bit deb? I know it should work, but what I can't install at all, I can't even run 32-bit.

Unfortunately, no. Unless Tepples is 64-bit. I don't know where to begin...and the help has disappeared!


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 03, 2012 10:57 am 
Offline
NESICIDE developer
User avatar

Joined: Mon Oct 13, 2008 7:55 pm
Posts: 1026
Location: Minneapolis, MN
cpow wrote:
I don't know where to begin...and the help has disappeared!


Shot in the dark here...can you try the *any*.deb packages on my website?
As Tepples discovered, for now, you'll need to download libc64-emulator_1.000-1_any.deb even if you have absolutely no intention of ever using NESICIDE to debug Commodore 64 programs with VICE. I haven't set it up so it truly dynamically loads the libs for the supported targets yet.

So, there's four *any*.deb packages. All I did was change the Architecture: from i386 to any. That's why it's a shot in the dark... :shock:

EDIT: LINK


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 03, 2012 1:42 pm 
Offline

Joined: Sun Apr 13, 2008 11:12 am
Posts: 6293
Location: Seattle
When we finish getting multiarch deployed in Debian/Ubuntu, you should be able to continue to just release i386 builds and have it Just Work on x86-64 machines.

Releasing debs marked with the _any architecture with ELFs inside is kinda not cricket.

I have a laptop with a Core2Duo running amd64 debian sid, and could set it up to do builds if that's all that's needed.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 50 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group