Unknown error in PHP's mail() when sending password

Discussion about the site's wiki, including bugs/issues encountered

Moderator: Moderators

Post Reply
tepples
Posts: 22017
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Unknown error in PHP's mail() when sending password

Post by tepples » Sat Sep 15, 2012 6:03 am

Because of the way sign-up is restricted, I have to create accounts for people with the "By e-mail" button. This appears to use the same MediaWiki infrastructure as the forgotten password button. However, I got the following error when I tried to create an account for nocash:

Login error
Error sending mail: Unknown error in PHP's mail() function.

User avatar
koitsu
Posts: 4218
Joined: Sun Sep 19, 2004 9:28 pm
Location: A world gone mad

Re: Unknown error in PHP's mail() when sending password

Post by koitsu » Sat Sep 15, 2012 6:55 am

I'm guessing WhoaMan will need to look at this. There are probably some php.ini [mail] block settings that need to be set / adjusted given the severe difference in how mail is set up on the new server vs. the old Parodius stuff.

WhoaMan
Posts: 168
Joined: Sat Oct 02, 2004 12:07 pm

Re: Unknown error in PHP's mail() when sending password

Post by WhoaMan » Mon Sep 17, 2012 9:50 am

I will take a look at this tonight after work. Sorry for not seeing this sooner, I have been going crazy on the house renovation and have not been on the computer much.
i dont have much to say

tepples
Posts: 22017
Joined: Sun Sep 19, 2004 11:12 pm
Location: NE Indiana, USA (NTSC)
Contact:

Re: Unknown error in PHP's mail() when sending password

Post by tepples » Sat Sep 22, 2012 11:20 am

Apparently the mail is still not reaching the user.

nocash
Posts: 1211
Joined: Fri Feb 24, 2012 12:09 pm
Contact:

Re: Unknown error in PHP's mail() when sending password

Post by nocash » Mon Sep 24, 2012 8:12 am

Yes, the user (that's me) still didn't receive a password for the wiki account.

WhoaMan might have fixed the account creation problem, but that didn't help in my case (since my wiki account was created before that fix). I have tried to get a "new" password by clicking "forgot your login details?" in the wiki, but that didn't work either (it tells me that a "reminder has been sent", but I didn't receive any such reminder - this might be another bug aside from the account creation problem).

If it's impossible to repair the "nocash" wiki account, could you please create a new account for me? Username "nocash123" and email same as in the old account, or alternately use the other email address that I've PM'ed to tepples & WhoaMan. If that's working then I'll be happy with it. If it doesn't work then we do at least know that the account creation still doesn't work.

User avatar
koitsu
Posts: 4218
Joined: Sun Sep 19, 2004 9:28 pm
Location: A world gone mad

Re: Unknown error in PHP's mail() when sending password

Post by koitsu » Mon Sep 24, 2012 8:26 am

I don't think there's any reason to make a new account; I do not think the issue has anything to do with your specific account. I think the issue may have to do with the MediaWiki configuration needing some config directives changed/set to work with the mail infrastructure that the new server now uses.

The same issue/complexity applied to the phpBB software here for the forum, as the mail infrastructure/bits used on the new server are significantly different (uses Google Apps) than when hosted on Parodius (we ran our own SMTP services). You can see confirmation of that fact in this sticky.

Bottom line: let WhoaMan work it out please. Patience. :-)

nocash
Posts: 1211
Joined: Fri Feb 24, 2012 12:09 pm
Contact:

Re: Unknown error in PHP's mail() when sending password

Post by nocash » Mon Sep 24, 2012 5:52 pm

Finally got my password! Thanks! It wasn't sent via email, but manually via PM.
Emailing might be still a problem for future account creations... but at least there's a way to get around it.

Now I can login to the wiki - but can't edit pages because I am not in the "trusted" user category! Can somebody please change that?

Btw. WhoaMan told me he can't get me the "trusted" status because he has no admin account on the wiki. How can you expect him to do the admin work without giving him an admin account? Can somebody please change that, too? At least, it seems to me... that he can't even test his account creation bugfixes without having admin rights. Or am I mistaken there?

User avatar
koitsu
Posts: 4218
Joined: Sun Sep 19, 2004 9:28 pm
Location: A world gone mad

Re: Unknown error in PHP's mail() when sending password

Post by koitsu » Mon Sep 24, 2012 11:58 pm

When things were hosted at Parodius, the Wiki was managed by tepples, Banshaku, and occasionally myself. phpBB was managed by a multitude of people. Things are different now. The server move and so on still has a lot of things that need to be taken care of, and this is one of them. There are multiple levels of access we're talking about here (system root access vs. wiki access vs. access levels within the wiki) and they're all separate. This is just how things are.

I'll update this post when I've had a chance to fix stuff up.

Edit: I've added you to the trusted group, and it looks like (from wiki edits) that WhoaMan already figured out how to add himself to the appropriate sysop and bureaucrat levels in the Wiki. There is a separate moderators-only topic where we're discussing changing things to make things easier (for ourselves as well as folks who want to do wiki editing in the future).

nocash
Posts: 1211
Joined: Fri Feb 24, 2012 12:09 pm
Contact:

Re: Unknown error in PHP's mail() when sending password

Post by nocash » Tue Sep 25, 2012 7:37 am

This is just how things are.
No problem. That troubles are to be expected when switching to a new server and new mail protocol, and as WhoaMan wasn't involved in the old server, it'll be twice as difficult for him to figure out what needs to be changed.

Okay, the wiki editing is no working for me. Big thanks to tepples, WhoaMan, and koitsu for creation & password & unlocking!

Post Reply