Project compiles, but has missing sections?

Discuss technical or other issues relating to programming the Nintendo Entertainment System, Famicom, or compatible systems.

Moderator: Moderators

Post Reply
WinslowJosiah
Posts: 2
Joined: Sat May 08, 2021 1:48 pm

Project compiles, but has missing sections?

Post by WinslowJosiah » Sat May 08, 2021 2:12 pm

I'm trying to get into NES programming from scratch after having failed the last time I tried. I got a version of my project to compile at one point, but I decided to rework some sections, and now I don't know what I did, but somehow my code compiles but doesn't run.

After inspecting it with FCEUX and YY-CHR, I found out that apparently the vectors and CHR data were not being included in my project, even though my code and configuration settings for both sections of memory should have been correct.

(Just as a side note: the code related to updating the nametables is untested, so even if this issue is fixed it might not function correctly. But at that point, that'll be my problem.)

What exactly is wrong here? (Also, are there any tips I should know about how to make my job easier when using multiple files? I tried to figure out how to use include files, but then it doesn't compile.)
Attachments
titol.zip
My project (warning: untested)
(15.98 KiB) Downloaded 40 times

User avatar
Controllerhead
Posts: 291
Joined: Tue Nov 13, 2018 4:58 am
Location: $4016
Contact:

Re: Project compiles, but has missing sections?

Post by Controllerhead » Sat May 08, 2021 4:47 pm

You have 1 16KB PRG bank in your header instead of 2. The vectors load properly now:

Image
Image

WinslowJosiah
Posts: 2
Joined: Sat May 08, 2021 1:48 pm

Re: Project compiles, but has missing sections?

Post by WinslowJosiah » Sat May 08, 2021 5:00 pm

I just knew it had to be something stupid like that. :roll:

Thanks!

Post Reply