It is currently Sat Nov 18, 2017 4:33 pm

All times are UTC - 7 hours





Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Sep 15, 2017 9:46 am 
Offline

Joined: Tue Feb 14, 2017 9:50 am
Posts: 38
So I have a weird problem, trying to dump a previously completly undocumented unlicensed game by Dragon Co.
From what I know, all Dragon Co games run on mapper 4, so I expect this one as well but it refuses to dump. It will always stop when trying to dump the CHR with a "libusb0-dll:err [control_msg] sending control message failed, win error: atached device not working correctly (…)" or "no error" (with the script ending early/not generating a ROM, heh).
Setting a CHR size of 0 generated a working PRG rom with mmc3_v2 script and it plays fine (screen all black, music plays, buttons reacts etc.)

The error is also generated with any other script. Yes, even with the NROM script and that's weird part. I could see it working on some MMC3 variant and eventually not dump correctly with mmc3_v2.ad but all of them terminating when trying to dump the CHR? No.
Anago also often returns "maybe cartridge connection error" while the pins are super clean and seems to be perfectly aligned with the connector. All my other cartridges dumps fine and aren't so picky regarding the position in the connector.

I can provide the PRG if necessary.
PCB:
Front: http://image.noelshack.com/fichiers/201 ... g-5819.jpg (the capacitor is actually connected, I checked it with a voltmeter)
Back: http://image.noelshack.com/fichiers/201 ... g-5820.jpg

For anyone curious, the game is called "Panda Baby" and it's a fairly bad Donkey Kong Country backport. Here's some terrible gameplay I just recorded after receiving the game. The game has really poor collision detection as well (you can see me experiencing it multiple time there).


Last edited by MLX on Wed Sep 20, 2017 12:05 pm, edited 2 times in total.

Top
 Profile  
 
PostPosted: Fri Sep 15, 2017 11:14 am 
Offline

Joined: Sun Apr 13, 2008 11:12 am
Posts: 6442
Location: UK (temporarily)
The libusb error implies that the Kazzo took too long to do something and Windows's USB stack timed out.


Top
 Profile  
 
PostPosted: Fri Sep 15, 2017 12:53 pm 
Offline

Joined: Tue Feb 14, 2017 9:50 am
Posts: 38
I'm guessing the mapper is doing something weird but I still don't get why NROM won't even work. The kazzo is fine, I can dump my other cartridges perfectly.


Top
 Profile  
 
PostPosted: Fri Sep 15, 2017 1:56 pm 
Offline

Joined: Sun Jun 12, 2011 12:06 pm
Posts: 244
Location: Poland
Maybe there is some kind of protection - if you don't set proper values of some bits in CHR register, internal diodes conduct high current which causes drop of voltage in cartridge (and Kazzo) and causes Kazzo to reset?
Do you hear windows' beep when you start dumping CHR which signals that device has been removed from USB for a while?


Top
 Profile  
 
PostPosted: Fri Sep 15, 2017 2:16 pm 
Offline

Joined: Tue Feb 14, 2017 9:50 am
Posts: 38
I haven't noticed windows seeing the device as unplugged for a short time. I could even press the dump button again miliseconds after the error from the previous attempt, led to the same point.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group