Page 1 of 1

NESRGB no video after install. Please help

Posted: Sun Oct 11, 2020 12:42 am
by rodri042
Hey everyone,

I've been trying to install the NESRGB mod but I can't get it working. Currently:
- It shows a black screen through RGB-CSYNC with a palette selected (pin 3 and GND bridged). OSSC says that it's receiving a 262p signal.
- It shows garbage on screen and crackling noise through composite outputs with palette in OFF (all pins without shorts).

Other details:
- Jumper J3 is shorted to use the internal voltage regulator
- Jumper J5 is shorted as the console is NTSC

What I've tried so far:
- The PPU works. I've removed it from the NESRGB and run 40 cables into the NES motherboard (to avoid having to resolder again) and it works well and has both video and audio.
- Continuity tests in all joints (top pins from the PPU with top pins from the bottom, and bottom pins except 2-9 and 14-17 are making good contact too). Except...

The CLK pin. It has no continuity to the bottom leg that goes to the motherboard. I joined both things with solder but it became worse (no video through composite and a "NO SYNC" error on the OSSC).

What can I do to test if there's a broken trail from that pin? Or how should I debug this in general? I don't have knowledge of the NES hardware and I only have a multimeter to test, so I'm a little lost here.

Thanks for reading!

Re: NESRGB no video after install. Please help

Posted: Sun Oct 11, 2020 6:40 am
by dink
CLK is pretty important, try using a wire jumper and make sure there is a good (perfect) connection w/continuity tests, and that it's not shorted in any way.

Re: NESRGB no video after install. Please help

Posted: Mon Oct 12, 2020 6:05 am
by rodri042
I ended up resoldering all PPU points and it worked! I guess I had some cold solder joints in some of the pins that are hard to test (2-9 and 14-18) because they're not bridged directly to the motherboard.

Also, I was using photos from old versions of the board where the CLK pin was one of the "direct" pins, but that's not correct for the last 2019 revision.

Anyway, user error. Thanks @dink for your suggestion!