nesdev.com
https://forums.nesdev.com/

Weird Controller Issue
https://forums.nesdev.com/viewtopic.php?f=9&t=7475
Page 1 of 1

Author:  NESHomebrew [ Fri Feb 11, 2011 8:57 pm ]
Post subject:  Weird Controller Issue

Something strange is going on with one of my consoles. After the console is "warmed up" a few minutes it quits reading controllers correctly. When you press the A button, it pushes A, Select, and Start (or maybe more, but I know for sure it presses those three). It is just the bare motherboard, but I've never had this problem before. I really don't know where to start looking with this problem.

I've tried multiple controllers, reconnecting the stock shielding, Different controller plugs, different adapters. I'm stumped.

Author:  3gengames [ Fri Feb 11, 2011 9:02 pm ]
Post subject: 

Sometimes parts heating up causes the part to fail, I've seen it with an Xbox before. And 360 of course with the old (RROD)


Maybe cool some hardware that is used to read the controller and see if it helps, if it does, it needs replaced. If not, good luck!

Author:  koitsu [ Sat Feb 12, 2011 6:32 am ]
Post subject: 

What console is it?

Author:  tepples [ Sat Feb 12, 2011 9:04 am ]
Post subject: 

If it's an NES or a Super NES, then perhaps the clock signal is going through a poor connection. Have you tried another controller? I had an SN ProPad fail like that: pushing B pushed everything.

Author:  NESHomebrew [ Sun Feb 13, 2011 12:38 am ]
Post subject: 

Sorry, it is a NES. What 3Gen said reminded me of something though. I have a socketed CPU, as it used to be my copyNES console. Maybe something is up with that?

Author:  3gengames [ Sun Feb 13, 2011 10:16 am ]
Post subject: 

I'd remove all the chips from their sockets and clean them (The wieman for the connectors works well) and re-seat all the chips. Some sockets are iffy.

Author:  NESHomebrew [ Wed Feb 23, 2011 11:41 pm ]
Post subject: 

Update: Seems to be working now. I polished the pins on the CPU and now it is working perfectly!!! Thanks for the help guys.

Page 1 of 1 All times are UTC - 7 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/