It is currently Fri Dec 15, 2017 8:45 pm

All times are UTC - 7 hours





Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Tue Nov 04, 2014 6:15 pm 
Offline
User avatar

Joined: Sun Jan 27, 2013 7:30 pm
Posts: 61
Anyone have any clue what's going on here? I have already swapped out the two 40H368's. Super Mario USA is one of the only games that seems to be working still funny enough. Wish I had a 'scope. :)


Top
 Profile  
 
PostPosted: Tue Nov 04, 2014 7:50 pm 
Offline

Joined: Sun Apr 13, 2008 11:12 am
Posts: 6534
Location: Seattle
I'm having a lot of difficulty thinking of a reason that it would work in some games and not others... subtle timing flaws? Stray capacitance?


Top
 Profile  
 
PostPosted: Tue Nov 04, 2014 8:45 pm 
Offline
User avatar

Joined: Sun Jan 27, 2013 7:30 pm
Posts: 61
Utterly bizzare... I was poking around with a high-ohm resistor tied to +5V and touched pin 39 on the CPU. It made it snap out of it. Now all games work again..? (without said resistor) What?


Top
 Profile  
 
PostPosted: Thu Nov 06, 2014 9:57 am 
Offline

Joined: Tue May 28, 2013 5:49 am
Posts: 928
Location: Sweden
Super Mario USA is known to use a different controller reading routine than most other games, since external controllers doesn't work for it. Maybe that has something to do with it working.


Top
 Profile  
 
PostPosted: Thu Nov 06, 2014 11:53 am 
Offline

Joined: Sun Sep 19, 2004 11:12 pm
Posts: 19348
Location: NE Indiana, USA (NTSC)
39 is the strobe.

If a game that doesn't read controllers connected to the DA15 expansion port (bit 1 of $4016 and $4017 read) works, but a game that does read those controllers doesn't work, one possibility is that games are seeing all buttons on the external controller always pressed. See if something is pulling pin 13 of the expansion port (connected to bit 1 of $4016 read) low. Do you have a rewritable cartridge in which you can run a test ROM that I can make for you?


Top
 Profile  
 
PostPosted: Thu Nov 06, 2014 2:57 pm 
Offline
User avatar

Joined: Sun Sep 19, 2004 9:28 pm
Posts: 3192
Location: Mountain View, CA, USA
tepples wrote:
39 is the strobe.

If a game that doesn't read controllers connected to the DA15 expansion port (bit 1 of $4016 and $4017 read) works, but a game that does read those controllers doesn't work, one possibility is that games are seeing all buttons on the external controller always pressed. See if something is pulling pin 13 of the expansion port (connected to bit 1 of $4016 read) low. Do you have a rewritable cartridge in which you can run a test ROM that I can make for you?

Possible to use this test ROM (note: somewhat NSFW graphics) to determine that? I mention this possibility because of the controller rework done here.


Top
 Profile  
 
PostPosted: Sat Nov 08, 2014 4:36 pm 
Offline
User avatar

Joined: Sun Jan 27, 2013 7:30 pm
Posts: 61
Thanks to all of you but especially Tepples for helping me out. It was a short between pin 12 and 13 on the expansion connector (tin whiskers?) that caused the erratic behavour. :roll:

You're the best, all of you! :mrgreen:


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group