It is currently Thu Aug 16, 2018 9:11 am

All times are UTC - 7 hours





Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: gcc rm problem?
PostPosted: Thu Aug 09, 2018 5:37 pm 
Offline
Formerly Fx3
User avatar

Joined: Fri Nov 12, 2004 4:59 pm
Posts: 3137
Location: Brazil
How do I fix this thing? :shock:
Attachment:
gccerror.png
gccerror.png [ 5.83 KiB | Viewed 116 times ]


Top
 Profile  
 
 Post subject: Re: gcc rm problem?
PostPosted: Thu Aug 09, 2018 5:53 pm 
Offline
User avatar

Joined: Sun Sep 19, 2004 9:28 pm
Posts: 3474
Location: Mountain View, CA
This looks like incorrect use of slashes for the environment type or Makefile. Windows uses \ for a path delimiter, UNIX (which is partially what MinGW/MSYS is) uses /. Some environments (MinGW/MSYS vs. Cygwin) can actually "translate" one from the other, kinda sorta but not really but kinda yes but sorta not -- yeah, this sentence makes no sense because it's very hard to explain when it works vs. when it doesn't. Plus, language barrier.

I would refer to MinGW/MSYS documentation and/or GNU Make for how to address this. You may need to set an alternate shell. This is certainly a common problem.


Top
 Profile  
 
 Post subject: Re: gcc rm problem?
PostPosted: Thu Aug 09, 2018 6:06 pm 
Offline
Formerly Fx3
User avatar

Joined: Fri Nov 12, 2004 4:59 pm
Posts: 3137
Location: Brazil
Thanks for the tip. Yeah, I had placed the string "C:\MinGW\msys\1.0\bin\" inside the makefile. I removed it (only the "rm" now) and... it worked like a charm.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group