Newbie needing some help. Strange problems with NES installed with Flashing Light Win from ArcadeWorks

Discuss hardware-related topics, such as development cartridges, CopyNES, PowerPak, EPROMs, or whatever.

Moderators: B00daW, Moderators

cmb1100
Posts: 12
Joined: Sat Nov 23, 2019 10:47 pm

Re: Newbie needing some help. Strange problems with NES installed with Flashing Light Win from ArcadeWorks

Post by cmb1100 » Wed Dec 04, 2019 5:13 pm

Okay. I bought an EverDrive N8, put ROMS on it and tried it out on the CRT. Nothing. Black screen unless it’s Super Mario Bros/Duck Hunt or very occasionally Gradius. Anything you guys can think of. Maybe I need to put the RF shield and top back on maybe that’s why it’s not playing because of RF interference??? I’m grasping at straws now because I’ve thought of every common problem I can think of. It plays SMB/DH very well, fun game great wonderful but nothing else!!

lidnariq
Posts: 8767
Joined: Sun Apr 13, 2008 11:12 am
Location: Seattle

Re: Newbie needing some help. Strange problems with NES installed with Flashing Light Win from ArcadeWorks

Post by lidnariq » Wed Dec 04, 2019 5:30 pm

I'm sorry, I really literally can't think of any reason that only one MHROM game would work but a random NROM game wouldn't.

I'd throw a logic analyzer or oscilloscope at it and hope I found something going wrong digitally.


.... well, ok, maybe I'd try replacing the CPU's RAM on the mainboard.

cmb1100
Posts: 12
Joined: Sat Nov 23, 2019 10:47 pm

Re: Newbie needing some help. Strange problems with NES installed with Flashing Light Win from ArcadeWorks

Post by cmb1100 » Wed Dec 04, 2019 6:08 pm

I don’t get it.
I don’t get it.
I really was hoping it wouldn’t be chips on the board that need replacing. I’ll have to send it somewhere that repairs retro consoles because I don’t have the wherewithal to do it myself, skills or equipment wise. No solder braid or desoldering irons here and I’ve never done that sort of work myself.

cmb1100
Posts: 12
Joined: Sat Nov 23, 2019 10:47 pm

Re: Newbie needing some help. Strange problems with NES installed with Flashing Light Win from ArcadeWorks

Post by cmb1100 » Wed Dec 04, 2019 6:17 pm

Okay I found something odd. I accidentally moved the EverDrive while the power was on and when I did the console shut off even though I hadn’t touched the power button. I’m not sure if that means anything though. I’m sorry I keep going through stuff but I really want to exhaust every possibility before I put it on eBay or try and have someone fix it for me

lidnariq
Posts: 8767
Joined: Sun Apr 13, 2008 11:12 am
Location: Seattle

Re: Newbie needing some help. Strange problems with NES installed with Flashing Light Win from ArcadeWorks

Post by lidnariq » Wed Dec 04, 2019 6:49 pm

Something shorted +5V to ground. (That's the only thing that can cause that symptom.)

I suppose you could see how cleanly the card edge connector lines up.

Post Reply